Error message when running “Solutions” in Butterfly

Hello people,

I am fairly new to Butterfly and OpenFOAM. I have tried to run simulations on a project, which seems fine in terms of meshing. However, when i run the “Solution”, an error keeps coming up. Translated into English, I would say that it says “The action is not initialized” (see picture).

I have set the “End time” to 1000. When I run the “Solution” in parallel, it makes a 1000 iterations (or so it tells me) and then gives me the error message. When not running in parallel, the simulations stops at about 200 iterations every time with the same error message.

Has anyone stumbled upon this before, and does anyone have a solution on how to fix the problem?

For confidential reasons I am not allowed to upload the Grasshopper file.

Thanks in advance :slight_smile:

I am first time seeing this. Can you recreate this error in a different GH file that does not breach confidentiality and share it? Are you using Rhino 6? If yes, can you try rhino 5?

Hello @devang

Thanks for the quick reply and suggestions!

Given that I haven’t found it anywhere on Grasshopper Forum and GitHub, I suspect that the error message doesn’t occur that often - which of course is a good thing.
I could try to make a somewhat similar file during the weekend. I know that would be a lot easier in terms of troubleshooting.
I am using Rhino 6. I can give it a go in Rhino 5, if you think that is worth trying.

Please try in Rhino 5 to be sure just in case.

Hey @devang

It seems I’ve figured out the solution to the problem. I thought I could be clever and link up a single Boolean Toggle to all the different steps of the simulation, meaning I could just set the Boolean Toggle to “True” and then let the whole simulation run over night.
However, it seems that something gets tangled between the SnappyHexMesh and Solution when doing so. If I manually set the different steps to “True”, for example Solution after SnappyHexMesh is done refining, then I don’t get the error message and the simulation runs smoothly both in parallel and with a single CPU (still working in Rhino 6).

In a perfect world it could be nice to have the option to just switch on every step in one go, since SnappyHexMesh takes quite some time to finish, but I can easily live with this :smiley:

Thanks again for your suggestions. I will consider this topic answered and ready to be closed.

Have a great day!

1 Like

We should be able to make this work in the near future, it’s just a matter of writing the case files instead of running and automatically generating a bash script.

Hi @jonaswlaursen, @devang, @TheodorosGalanos

I run several simulations during night using colibri. But sometimes I got the issue, that for the last or first variant it deletes the folders of the timesteps when it´s done. In that casse the results seem ok but there´s only timestep 0.

But this was only when I did the meshing and the simulation at once, at least I think so. When you first do the meshing for all variants, then hook up the case from wind tunnel to run simulation it should work I guess.

Your post is not very clear. Can you please start a new topic and elaborate on what you are trying to do!

Hi David,

I would suggest you follow the typical practice of GH parametric designs and name each case according to the input parameter set (eg. wwr_10_or_N_angle_45)