Error of annual result to data

When I tried to use Annual result to data, I got an error.

  1. Solution exception:pass ‘C:\Users\………\1656.44327133507\sun-up-hours.txt’ not found.

I’m not sure about sel_pts and all_pts. Is there a cause there?
Is it correct that sel_pts is the point of data you want and all_pts is all the points in the simulation?

If anyone knows the cause, please let me know!


It is irritating that this component needs this input, it didn’t in its earlier incarnations.

I guess you are missing the vectors, as well as the points.

Am on mobile and can’t check, but think perhaps the easiest solution is to evaluate the mesh and get points and vectors from that component and connect to the annual to data.

And a merry x-mas to you,
Little Buddha

Thanks for the reply!

I tried and got the same error.
Is this method wrong?


Am still not on a PC, so cant check up on things.

But it does look, from your screenshot, that the results are already available as a list. The annual to data component is only used when there is an hourly data collection, that does not look to be the case here.

Please read up on:

And follow this guide for follow up:

Thanks for letting me know!

I will try another way.