Error: unexpected keyword argument "silent"

Hi, unfortunatly I got this error and cant find the solution:

  1. Solution exception:run() got an unexpected keyword argument ‘silent’

Component: LB Annual Daylight

I already tried snyching the grasshopperscript.

Any ideas?

You are using a newer component while having an older version of the Ladybug Tools core libraries installed. Reinstalling the latest version will usually fix the issue. Using the “LB Sync Grasshopper File” component to sync the comments on your canvas with your installed version could also help.

But wasn´t it possible to have the legacy and the 1.5 Versions installed?

Hi Ben -

Legacy and LBT, yes. But you can’t mix those components.
If I read Chris’ comment correctly, though, you have an older LBT version installed but some components are from LBT 1.5.

1 Like

I only have legacy and the 1.5 installed. Thus i shouldn´t get this error. I did use the unistall option and reinstalled both versions, but I still do get the error with a few components. For example importing/analyzing weather data with the 1.5 Tools work. It´s just the components that use Radiance I believe.