Error: vertex size mismatch between base surface

Hi,

I have an error in my model. It says “vertex size mismatch between base surface” when I include 3rd floor during with entire model. To me, it’s a very simple model, still, there are problems with intersections. Could you help me with this issue?

Please find the files included.
3D_Design.3dm (191.3 KB)
3D_Design.gh (649.6 KB)

I tried your model. It ran without any errors at my end. Can you post a snap shot of the error?

@devang, do you have any idea how to solve this issue?

Whenever facing such errors. Recreating the problematic geometry has helped me in the past.

But according to you, the model run without any error.

You are using meters in rhino right?

yes, rhino units is in meters.

Cheek tolerance value.
-A.

What would be an optimum number ?

Check what is your setting. Try from 0.01 to 0.001 …
Just guessing.
-A.

Tolerance did not help. However, I had to redraw the model and tried the 64bit rhino and it worked.

I am facing the same problem. Should I redraw the model?

maybe that’s the best idea.
I used a procedure like the following video
https://www.youtube.com/watch?v=jMmBso9bL14&t=183s

Thanks for your reply.Yes. I did follow this video. It seems that it is the problems on the geometry. when I change my geometry to other geometries, it works. But If I keep the original one, there are still warning.