Error when running Daylight Factor recipe in LBT1.1.1

Hi,

I’ve recently installed the latest version of Ladybug Tools (v. 1.1.1) and I have been trying to run the daylight factor sample file, but I end up getting an error report stating: “c:\user…” is not recognized as an internal or external command, operable program or batch file."
I have been unable to solve the error, and thus is unable to use the script:

I’m used to working in the legacy version of Ladybug Tools and have never experienced this problem before.

Thanks for your time.

Hi @Alexanderharvey, what’s the username on this computer? Does it have a white space?

I thoughts we’re catching this case but maybe not. @chris knows better than I do if that’s the case.

Hi @mostapha, the username and user folder used to have a whitespace which Microsoft assigned the account when I first set up the new computer. However, I’ve since been changing the username, folder name and registry to try and solve the problem with the whitespace, but it seems it hasn’t worked.

If I can’t find a solution I’ll have to make a clean install of Windows, which will lose me a couple days work.

Hi again, I’ve managed to solve the problem. As stated in my earlier comment, I had already changed my username and folder to not have any whitespace, but that alone didn’t solve the problem. So I chose to remove the ladybug.tools folder and the folder in Grasshopper Components and do a reinstall of the Ladybug Tools and now it works like it should.

So for anyone encountering problems due to whitespace in their user directory, try changing the username and directory so they don’t include the whitespace and then do a reinstall of Ladybug Tools so it registers the new directory correctly.

1 Like

Hi @Alexanderharvey, thank you for updating the thread. @chris, I think this is something that we should handle on our side though. It’s either a bug in the command that the component executes or it happens when queenbee-luigi tries to execute it. Let me know if it’s the latter and I will try to fix it.

This has been fixed in the development version of the plugin for the last couple of months:

I was able to run the recipe with a space in the path just now:

@chris Cool! I’m looking much forward to the next version of the plugin.

I made the mistake both in the title of this topic and in my text by writing that I was using LBT 1.1.1. I was using the released version of LBT 1.1.0, so maybe that is why the problem appeared, since this has been fixed in the development version as @chris stated :slight_smile:

1 Like

@chris @mostapha
Hello dears
I am facing the same error. can you please tell me how to update the component using the attached link? I tries to update the code but I failed.
I am using LBT 1.1.0
Please help!

Uninstall your old LBT and update to LBT 1.3. Then, you can use the LB Sync Grasshopper File component to update your Grasshopper definition to be compatible with LBT 1.3.

I already reinstalled the version and fixed the issues. Thanks for your kind support

1 Like