Error with earth tube component


I am having a problem with the earth tube honeybee component. when I connect the HBZone the component shows an error that says:

  1. Solution exception:No se puede encontrar una parte de la ruta de acceso ‘C:\Program Files\OpenStudio 1.12.0\share\openstudio\EnergyPlus-8-5-0PreProcess\CalcSoilSurfTemp\exeinputs.txt’.

“A part of the access route can`t be found”

Could somebody please help me. I`ve tried in other computer and the same thing happens. Am I doing something wrong? or is there a problem with the component?.

Would you know of another way to model an earth tube?

Thanks in advance.

Arturo Reyes

ModeloBIBLIOTECA.3dm (399 KB) (680 KB)

Hi Luis,

Please try the file attached, somehow it looks like a / got left out of the filepath.

Let me know how it goes.

modelobibliotecaAS (690 KB)

Hello Anton,

I tryied the file you kindly send me. But now it shows a similar error in a diferent path as shown in the picture.

Thank you again.


I don´t know if this helps.

Based on the error I think it’s happening because Honeybee finds the EnergyPlus folder under OpenStudio installation on your machine which is a stripped down version of EnergyPlus installation and doesn’t have the files that Anton is using for modeling earth-tube.

Hello Mostapha. Thanks for the response. I am sorry but I am not very savvy in this topic. Should I reinstall OpenStudio?. Or what should I do?


I think I’ll need to take a closer look at this one can you add me on skype its just my name I’ll call you and have a look at whats going on, on your computer

Thank you very much Anton,

I am available at your earliest convenience.


I’ve the same problem !

“1. Solution exception:Could not find a part of the path ‘C:\Program Files\OpenStudio 1.14.0\share\openstudio\EnergyPlus-8-6-0PreProcess\CalcSoilSurfTemp\exeinputs.txt’.”

Have you found what cause the problem?

Thank you,


Hi Mohammed.

I fixed this recently so you are using an outdated version, until my latest pull request gets merged find a working copy attached here. It will work with the Export to OpenStudio component and Run E+ component (502 KB)

Thank you Anton,

I tried the new file and still have a problem

“1. Solution exception:Could not find file ‘C:\Program Files\OpenStudio 1.14.0\share\openstudio\EnergyPlus-8-6 0\PreProcess\CalcSoilSurfTemp\CalcSoilSurfTemp.out’.”



This is very strange as it works fine on my machine, do you have skype or gchat?

I’d like to take a look at what is happening add me: ajszilasi at gmail

or antonszilasi skype

Hi Anton:

I added you in Skype. You can call at your convenience.

My email: alshayebm at hotmail

Thank you,