Fail: CreateRadFolder and doe2 properties to the Model

I run the HB annual Daylight simulation but failed. I have updated my ladybug tools to the latest version via pollination. I also check the Luigi Execution Summary. But I do not know how to fix it. I upload a link of the logs in TXT via onedrive.
logs.log
Thank you very much.

The battery showed below

  1. Solution exception:
    The recipe failed to run with the following error(s):

2024-05-22 12:58:58 ERROR: “CreateRadFolder” failed. See below for more information:
Exception: Failed to apply doe2 properties to the Model: ‘rooms’

Execution Summary
Scheduled 17 tasks of which:

  • 5 ran successfully:
    • 1 CreateDirectSky(…)
    • 1 CreateSkyDome(…)
    • 1 CreateTotalSky(…)
    • 1 GenerateSunpath(…)
    • 1 ParseSunUpHours(…)
  • 1 failed:
    • 1 CreateRadFolder(…)
  • 11 were left pending, among these:
    • 2 were missing external dependencies:
      • 1 PrepareFolderAnnualDaylight(…)
      • 1 RunTwoPhaseDaylightCoefficient(…)
    • 2 had failed dependencies:
      • 1 PrepareMultiphase(…)
      • 1 _TwoPhasePrepareFolder_ae79e661Orchestrator(…)
    • 5 had missing dependencies:
      • 1 AnnualMetricsPostprocess(…)
      • 1 CalculateTwoPhaseMatrix(…)
      • 1 LetAnnualDaylightEnhancedFly(…)
      • 1 _Main_7efbbeb4Orchestrator(…)
      • 1 _Main_ae79e661Orchestrator(…)
    • 2 was not granted run permission by the scheduler:
      • 1 PrepareFolderAnnualDaylight(…)
      • 1 RunTwoPhaseDaylightCoefficient(…)

This progress looks :frowning: because there were failed tasks

I fix it. I make a mistake on the connecting. I connect the HB face to the HB model directly. Actually, I need to connect to the HB room first and then HB model. It fix the question.

Hi @SHIHAO ,

Very sorry that you experienced this bug. It was fixed here:

… and you can get the fix with either the “LB Versioner” component or with the latest Pollination single-click installer. My guess is that one of these two is what actually fixed it for your case here.

1 Like

Hi @chris,

The bug still seems to happen to me when the HB Model only has shades.
image

I’ve made sure to be on the latest version.

Kind regards,
Marc

Hi @marctavenier, did you download the latest Pollination Grasshopper installer? What version of the installer did you use?

1 Like

Mostapha’s on the right track here. I forgot this is one of those rare bugs that the “LB Versioner” component can’t fix for you.

You must install via the latest Pollination installer to get the fix on your end.

I just corrected my statement above with some strikethroughs.

1 Like

Thank you for your replies @chris @mostapha!
I just updated my installation via the Pollination installer v1.48.25 and synced the Grasshopper file, and that seems to have fixed the issue :slight_smile:

2 Likes