Fail to Update HB and LB

I was having problems with HB and I decided to update the plugin by using the HB update component and I returns an error:

I can reproduce this on my system. I will take a look soon. Thanks for reporting. - Mostapha

Hi again Claudio, I spent some time now and tested the process. Looks like github is blocking automated requests for downloading the files. There are workarounds for this which I will apply once I get a chance… Meanwhile you need to update them manually! :expressionless:

If you clone the repo on your local drive you can provide the address to userobjects, similar to this image:

Just to report: Adding the panel indeed doesn’t report an error, but … the path you give in it remains empty. Nothing is downloaded (in my end at least).


Hi Abraham, you need to download the files manually and then let the component know where to find them. This is the address to the files on my system and you need to modify it based on the location of userObjects on your system. Best, -Mostapha

Hi Abraham, FYI I just committed a new version that should fix this issue.

Hi Mostapha,

Thanks but …

I suppose the other discussions relate to this one also. I’m using the file you attached in other thread.

So i downloaded the and copied it to the directory mentioned in the LB_Updater. But still don’t update the file. Still having the same message.

I closed Rhino and reopened it but still not working.


Hi Abraham,

Thanks. Can you tell me what is the folder? Hopefully I didn’t upload the wrong file to box. Can you try the attached file?

I need to go to bed right now but I will check again tomorrow after work so please take your time!

Mostapha (15.5 KB)

No problem,

The message says:

Downloading the source code…IOError(<System.IO.IOException object at 0x000000000000002B [System.IO.IOException: Authentication failed because the remote party has closed the transport stream…]>,)Download from the link below and copy the file to

c:\Program Files\Rhinoceros 5 (64-bit)\Plug-ins\IronPython\Lib and try again also unblocked the file.



Thanks. Can you please try this file. It will download two files to c:\ladybug on your system and if it works I can get update components fixed later:

Indeed two files were downloaded :slight_smile:
The report says:
3.33856201172 1421862742.82

Perfect! It means that I can sleep tonight with two less issues jumping on my nerves! :slight_smile:


In My case the did not work neither. The 2 files versions.tx. and a where downloaded to c:\ladybug.

The report gives this message

0.345413208008 1421863665.39

Thank you for your help

This one should close this discussion:…

GREAT! now it works =) Thank you very much Mostapha

Works Like a charm…get some rest now

thank you very much