Failed to find probs


#1

Hi
sometimes, when I change a BFgeometry after running solution I face “failed to find probes problem”. Although I check my mesh location and test points and all necessary alteration based on the new geometry ( all the components work in grey mode), the error remains.
Thanks for your solutions.


#2

Which component does give you the error?


#3

“loadporbsvalue” . And I did it once for a geometry and “loadporbsvalue” was red for “P” and grey for “U”


#4

The error means that the file is not created yet. Once you run the analysis the error will go away. The file should be created under PostProcessing folder.


#5

Running the analysis , I still face error as it is shown below the “loadporbsvalue” is not working because it couldn’t find P in …/postprocessing/prob/0 file


#6

Is it a temporary error or does it stay red during the whole run. If it’s temporary then you can just ignore it as it happens because the component tries to parse the results while OpenFOAM is generating the file and that can fail in some cases. If it stays like this during the run can you check the folder and see if created successfully inside the folder?


#7

It isn’t a temporary error. As it is shown in the picture there is no P file for the probs


#8

Thanks. Check when you create the probes and make sure you assign p and U for both fields.

Also it should be p (lower case) and not P (upper case).


#9

There is no error before running the simulation. I send BF file, Thanks for your recommendations.interior2.gh (507.8 KB)


#10

@EhsanFouladi, in your screenshot your input is a capital P. As I mentioned before it should be lower case p. P is not the same as p.


#11

sorry for my late response. I changed P to p and It worked.
Thanks


#12

Hello,
I am new to use butterfly and I try to run a simple simulation. The same error appeared "fail to find probe ". As you mentioned in this topic, I could find the folder where I can find p and U files. So what should I do to solve this error? Could you please help me to check it?
Thanks for all your help.

Nico


Capture2
20181030_outdoor_airflow.gh (107.1 KB)