Failed to import honeybee error


Your installation is missing the core python libraries.

How did you install the library? Did you use the installer component or did you only copied the user objects / components?

1): I just copy to the py to C:\Users\dell\AppData\Roaming\McNeel\Rhinoceros\6.0\scripts and
2): userobject to the C:\Users\dell\AppData\Roaming\Grasshopper\UserObjects;
i don’t kown how to do next?? please give me some sos.

Are you trying to install the version which is under development? Or are you trying to install honeybee[+] for daylighting which has been officially released? For the former we do not have an installer yet. There are ways to get it to work but is it the plugin that you are looking for.

For the latter see here: Honeybee[+] update component error: Solution exception:WindowsError

yes ,I know what you say that is the honeybeeplus’s installation. but
1):My honeybee is ok; and honeybeeplus is also ok!
2):but this honeybee-radiance isn’t ok; it’s red!
3): and this "honeybee [not honey-legacy] " is also not ok! it’s red too!
i 'm very sad ; I find many days about this problems , but i still don’t know how to solve it?
I am sorry to bother you, because I am disgusted with the red battery, so I have been trying to keep it running normally, but I haven’t found a solution
001 ![002|690x101]


oah…no!! * What’s wrong with my honebee run?!

I’m also experiencing the same errors and getting the Windows error (I tried the new file and running Rhino as admin without success)


Yeah, but I don’t know how to fix it,

I have this problem too. Does anyone have a solution to this problem?

For people getting this error with the new LBT plugin, this is because you did not follow step 4 of the Windows installation instructions correctly. Make sure you are running that .bat file WITH RHINO CLOSED.


Chris, I run the .bat file with Rhino closed, but still it doesn’t work.

Did you check whether Ladybug Tools work in your Rhino installation after you closed this window? The window you shared seems to indicate that everything went well.

I am experiencing the same problem with the latest version of ladybug tools. I followed the installation instructions (including running the .bat file with rhino closed). Any further pointers on how to solve this would be great.

Hallo, I have the same problem. I did this according to what chris said, it runs.


same… followed all of the steps, double checked all the file paths, and made sure that rhino was closed before running the bat file. The command line reads that it ran successfully, but all of the HB/LB components aren’t read in grasshopper and appear red.

Hi @chris & @devang,

The same issue occurs here. I have all the components in grasshopper but each and every one of them is labeled red with the comment “Failed to import ladybug.” Same also for honeybee or dragonfly components.

I did follow all steps on the installation guidelines for Windows with Rhino closed etc. After the .bat file runs, and even though we receive the following text from the cmd panel “Congratulations! Setting the search path…was successful:” it seems that when compared to the similar screenshot from the installation guidelines MarioAlves and I do not see the following path created (not sure if this gives out any hints of what else we can try):

C:\Users[USERNAME]\AppData\Roaming\McNeel\Rhinoceros\6.0\Plug-ins\IronPython (814d908a-e25c-493d-97e9-ee3861957f49)\settings\settings-Scheme__Default.xml



I also tried following your instructions from the thread “How to Manually Add Ladybug Tools to the Rhino Python Path” but still the same outcome.

This is the ultimate answer for anyone experiencing this issue with the new LBT plugin (1.1.0):

@chris.lzu , if you are still experiencing the issue with the LBT components after following those steps, then you did not do them correctly and you should try again.

I also realize that this issue has become entangled with a similar error in Honeybee[+] 0.0.06, which is completely separate from the issue with the LBT plugin. For this reason, I’m not sure if this thread is helpful to anyone anymore. So, if anyone has an issue with Honeybee[+] 0.0.06, please just open another issue.


@devang, the solution proposed by @chris worked for me!

1 Like

Thanks Chris,

I still have the problem with the import honeybee error. I have this issue though when I follow the instructions of the file. What can I do?