False Color Not Generating Valid Images

Hi everyone,

I’ve been having some problems with the false color image renderer. I can’t figure out why it is generating invalid images (only 1kb in size).

I’m including a the gh definition.

Controls are on the upper left corner.

Everything else works fine, the image based simulation does render out a scene and is can be converted to GIF.

I’ve also included copies of the original HDR and the 1kb false color HDR.

Let me know if you have any ideas.

Thank you,


FalseColor.rar (886 KB)


The uploaded file is not accessible. Ning is not allowing access.

Can you upload just the GH?



Im uploading unpacked files. GH, HDR images.

Just use any epw file to fill in the path included in the definition.



False Color.gh (502 KB)
London_Glare_glRatio_04Tvis_0817_IMG_Perspective@fc.HDR (103 Bytes)
London_Glare_glRatio_04Tvis_0817_IMG_Perspective_chkFile_h.HDR (444 KB)


Can recreate your problem. Your file works fine with me.

Did you succeed before in creating those files (in this example or another)? Maybe you are missing some of the programs to install? Can you check in your Radiance/bin folder if you have the falsecolor.exe?

Attached a file that i updated and is working. Also inserted the Sunpath, as for your other discussion.


FalseColor_AY.gh (542 KB)

Abraham ,

Just downloaded and opended your file. The sun path works fine.

However, the false color problem persists. I do have falsecolor.exe in the directories. The component is generating an image, albeit much smaller in size, which shouldnt be since its only altering RGB values of pixels.

Which OS are you running? I suspect this may be Windows related.


I’m using Windows 8.1. I don’t believe the problem is in the OS.

The small file you are getting is garbage. It is produced by the batch that is running the falsecolor.

Check if the falsecolor is blocked … and/or let’s wait Mostapha has some ideas.



Just figured it out…permissions error. I ran rhino as admin and the problem went away.

Had the same issue with IES VE.

Thank you so much for the support though and sorry for the wild goose chase.

best wishes,


Hi Mauricio,

Is it because you don’t have administrative access? If it is a permission issue you should be able to double click on the .bat file and generate the image.

If you have python installed on your system the other option is to download falsecolor2.py and use Python to run the py file. That will also solve the issue.