Forced parallelization (DF) in complex geometry with low number of sensors

Hi there,

I read a few discussions about the new versions not supporting the “min_sensor_count” input. But while I understand the reasons not to include this feature, I am currently battling with my specific case.

In my case, I only have 4 sensors, where I want to calculate the DF. The geometry is quite complex and I would like to have really precise results resulting in strict rad_parameters. I can set the number of workers to 4, but the preset minimal sensor count of 200 reults in only one CPU core working. This in consequence means, that the simulation takes hours to finish. Is there any way I can force the parallelization in this case? Setting 1 sensor for 1 worker?

Hi @zdenom,

If you set the workers to 4, and add line 73 in the DF component,

67.   if all_required_inputs(ghenv.Component) and _run:
68.       # create the recipe and set the input arguments
69.       recipe = Recipe('daylight-factor')
70.       recipe.input_value_by_name('model', _model)
71.       recipe.input_value_by_name('grid-filter', grid_filter_)
72.       recipe.input_value_by_name('radiance-parameters', radiance_par_)
73.       recipe.input_value_by_name('min-sensor-count', 1)

then it should split each each sensor to its own worker.

The min-sensor-count still exists in the recipe, it is just not exposed in Grasshopper.


Great, this works! Thank you!