genCumulativeSkyMtx error

I think i have connected “path” to “_epwfile” of genCumulativeSkyMtx in a right way (set one file path>.EPW file), it still contained a warning of “Download failed!!! You need GenDayMtx.exe to use this component. Please check your internet connection, and try again!” There’s no problem with the internet connection, is there something wrong with “GenDayMtx.exe” ?

Thanks in advance for your help. (18.5 KB)

Hi Chen,

You need to include the LB-Ladybug component. This is the “brain” of the whole other components.

-A. (38.2 KB)

Hi Chen,

In some cases the firewall doesn’t let the component to download the file.

If Abraham’s suggestion didn’t solve the problem download the attached file and copy it to c:\ladybug and you should be fine.


gendaymtx.exe (19 KB)

Hi guys,

me too I have the same problem…I copied gendaymtx.exe in c:/ladybug but it doesn’t work… But it is necessary a web connection! Because I’m working on windows by virtualbox and there I have some probelm with the wireless!!

I have intalled the latest version of ladybug…but the cumulativeskymtx seems to be older (version 0.0.57 and not 0.0.58)

Hi Davide, Did using the newer version of gencumulativesly solved the issue for you? -Mostapha

Thank you Mostapha, I solved the problem!!

Hi Mostapha,

I have the same problem too and I am using VER 0.0.58. in the genSkyMtx_Fixed file. The following steps are what I did:

  1. Update Radiance: installed radiance-4.3.a

  2. Download the gendaymtx (21kb) and copy it to c:\ladybug and c:\radiance\bin

  3. Update cumulative SkyMtx component in Grasshopper

However, I still have the same problem, could you check which steps I missed or did wrong? Thank you.

Hui Ling

Hui Ling,

You may need to also copy gendaymtx.exe to C:\Users\YOURUSERNAME\AppData\Roaming\Ladybug if you are not an administrator on your computer or you don’t have access to run exe’s from the C:\ drive.


Thank you, Chris! It works now.

Hi Guys…I have same problem as other guys but when I run Abraham attachment it works in my definition…without that gencumulativesky doesn’t work and cant find location mtx file…as Mostafa said I copied .exe file but it still doesn’t work…could you help me please

Hi Hanif, Try this:

If you are experiencing any issues with downloading gendaymtx, OpenStudio libraries and other Ladybug and Honeybee files, you can download all the files from this link as a .zip file and manually extract it to Ladybug folder: (

You can find ladybug default folder by checking the output of Ladybug_Ladybug component. It should be c:\ladybug or C:\Users%USERNAME%\AppData\Roaming\Ladybug depending on your user permissions.

Hi Mostapha…I tried this but still Gencum cant find .mtx file !

thank for your consideration

Hi Hanif,

Did you try to re-run your file after copying the files? In case Abraham’s file runs fine on your system then you are probably making a mistake in setting up your file. Can you upload your file and send a screen capture of the error?


HI Mostapha

Yes,I tried to rerun my file and even rewrite definition in new file but still dont work!now when I run Abraham’s File and connect them to radiation analyses it say that you need newer version of ladybug version is 0-0-58 ! (356 KB)

Hi Hanif, Thank you for the image. It is because how you have set up the user folder which has white spaces and '. You need to manually set workingDir_ to a valid address. Try to create c:\ladybug folder and then use a panel to set workingDir_ to c:\ladybug. It should work fine then.

Hi mostapha …could you tell me how can i use a panel to set workingDir?! the edit note of panel is off for me! I created c:ladybug folder and extract template files but it works just for Abraham’s file and when i rewrite def it doesn’t work ! thank you


Try the attached. See the group in red.

Hope it helps.

-A. (359 KB)

Thanks Abraham…it works…i didn’t care enough to gencum component inputs

Abraham, I have the same problem and did everything that was sugested above, but stll it doesnt work =((( What can be the problem?

Hard to say Yana,

Attached a working file with the EPW link you used.

This file has more updated components than those that you are using according to your picture.

-A. (359 KB)