Geometry Preparation for simulation

Hello There,

I’m following Mostapha’s Honeybee work (Honeybee_Grid-based_Daylight_Simulation_Example_III) however, it’s used 4 windows instead of 6 windows. The problem is when I added “Region Difference”, its result gives nothing (see image)

. See the following image for Mostapha
Is that a bug? GH file is (17.0 KB)


Hi @rsalelwani,
You windows were not co-planar to the wall you were trying to assign them to. I fixed that. (112.4 KB)

Thanks for replying Devang,

The window is still not recognized (see image)

Please check absolute tolerance in Rhino in Tools>Options>Units>Absolute units. Mine is 0.01 and units is meters.

1 Like

Thanks a lot Devang! Now it’s working!!

Regarding for Mostapha’s work, he didn’t assign the windows and when he used “Region Difference”, it’ works but for mine is not! any explained!

I think the culprit could be the non planarity of the wall and the window goemetry.

1 Like