HB Add Subface- subfaces don't match any parent faces

I’ve faced this challenge in a few scripts lately and not sure how to proceed?
The inputs being the geometry and the components shown.

Hard to say without the file, but seems that the openings and the walls are not coplanar. Can be it?

model_creation_workflows An.gh (460.2 KB)
temp.3dm (210.5 KB)
This is my file and gh @AbrahamYezioro

It is working fine for me:

Maybe your tolerance value is high. Set it to a lower value (0.001, or so).


I tried with both 0.001 and now 0.0001. It’s still the same story also in other scripts with this component. Tolerance of units model etc in Rhino? (that’s what I did, just to be sure)

I typically use a tolerance of 0.01 meters since this is also the hard-coded tolerance of EnergyPlus. Also, make sure your angle tolerance is 1 degree.

Lastly, make sure you are restarting Rhino after changing the tolerance since honeybee only loads the tolerance once when the GH definition is opened.

1 Like

Thank you Chris, it worked.

1 Like

Hey! I am new to Grasshopper.
I have this issue and I have changed Rhino tolerance to 0.01 and the degree to 1. I restarted Rhino and I am still getting this error. Please can anyone tell me what I am doing wrong.