HB Annual Daylight error: failed: SplitGridFolder

Hi @chris , on the same sample script, now the annual daylight doesn’t run. I notcied the recipe is updated to 1.3.1 after running versionner and sync.
Link Building Fin Study_simplified_forum.gh (171.1 KB)
Report out:
error report.txt (38.9 KB)
Log:
logs.log (37.2 KB)

You are a master at finding edge-case bugs, @XavierZhouLadybug !

I’ll investigate more when I get the chance but you have somehow managed to get the grid-splitting process that parellizes the calculation to split things into zero grids, resulting in this error:

While I’m investigating, you might be able to work around this issue by specifying a number of workers (3 or greater) in the recipe settings. If all else fails, going back to the last stable release will definitely fix this case.

Hi Chris, thanks for the quick response. Specifying number of workers doesn’t work. I’m going back to 1.3.0 (by “updating” back to 1.3.0 with versionner) for now.

Thanks again for reporting this bug, @XavierZhouLadybug . I wasn’t able to run your Grasshopper file but I was able to recreate this issue. It seems like it happens when you have a small number of sensors in your model. I just merged a fix into the development version of the plugin:

… and you should be able to get it with the LB Versioner in an hour or so.

Thanks again!