HB Annual Daylight 'Failed to generate SunPath'

When I try to run the Annual daylight component, I get the error seen on the image. All components are HB version 1.4.0, and runs without any problem on other people’s laptops that have the same HB version as me.
Is it anything to do with my laptop/HoneyBee, and if so what could I do to solve this?

Thank you in advance!

1 Like

I know that step can fail in the last stable release if the Wea is only for nighttime hours but that may not be the issue.

Can you try running the LB Sync Grasshopper file component in your definition to see if that corrects the issue?

I tried that too but it shows the same message in all recipes and even in different geometries. Is there another way to bypass this component (HB Annual Daylight) and simulate annual daylight ?

Can you upload the log file that should be at:


That could tell us exactly what went wrong.

Hello everyone, the same problem also here :worried:

I had the same issue, did you manage to solve it ?
please let me know

If someone can just upload a log file like I suggested, we can figure out what exactly went wrong and fix it.

Hi Chris, can you pleas tell me how I can find and share this log file?

Hi @FrancescoEmanuele,

You can find logs.log in a file path similar to this:


The exact path naturally depends on your username and the project folder of the simulation. If you can’t upload here, please share it somewhere else and provide the link here.

logs.log (20.8 KB)
logs.cfg (768 Bytes)

I found these two.
Please let me know if they are the right files

Hi @FrancescoEmanuele,

I can’t tell exactly why it happens by the error message. Are you able to share your Grasshopper file or the annual_daylight folder from where you found the log file? Either here or in a private message.

1 Like

Thanks for your reply Mikkel, I will try.
The file path is not clear clear yet for me.

You can take a look at this post, it is very similar to your problem, rule out whether it is the anti-virus software or firewall will radiance files to delete. :grinning:

1 Like

logs.log (22.9 KB)

This is my most recent one- the same recipe kept working but when I simulated in a different system, the problem occurs in other recipes too (with the daylight component not functioning)

I came across this error too (failed GenerateSunpath) when doing HB Annual Irradiance, but could resolve it by updating the Radiance files to latest 5.4a version. @Anyone and @js, perhaps your different systems had different Radiance versions?

For me however it’s still an issue as I’m using Accelerad for other Radiance tasks and would like to use the same for annual calculations. Accelerad fails the same way as 5.2a version of Radiance does for annual calculations.

For Daylight Factor for example, I can run it successfully with Accelerad (as long as radiance_check=False).

@chris, any ideas on what’s going on from the logs posted in here earlier, or why it would work on 5.4a and not 5.2a/Accelerad 0.7beta?

edit: I’m using LB/HB 1.5.0 and ran the LB Sync Grasshopper File beforehand.

I got this same error as well, failed Generate Sunpath for HB Annual Daylight, and I also downloaded Radiance 5.4a. I am also unable to find the log of the simulation according to the filepath sent. Also for me, my script is working on another laptop but not my own. Has anyone figured out a solution yet?

Hello, I’m sorry to bother you. Have you solved this problem?

Hi, I reinstalled Ladybug Honeybee Radiance completely and it started working for me again. I don’t know why it had stopped though.

1 Like

Hi, I also had to uninstall and reinstall Radiance, and make sure the Radiance folder was placed in the right file location (C:\Users*your computer name*\ladybug_tools). Then it worked!

1 Like

I will try the same.
Thanks for sharing