HB Annual daylight simulation_cannot find the results

Hi guys,

I’m trying to learn more and more about the great capabilities of HB an LB. Unfortunately sometimes I remain stuck because of some issues.

Right now I’m having a problem with the Annual daylight simulation component. While for the other simulations I easily change working directory according to the computer path, I cannot do that with this component.

Could someone help me?

Thank you in advance!


Daylight simulation_Annual Daylight problem.gh (505 KB)

Hi Marco, Do you have Daysim installed on your system? I guess Honeybee can’t find daysim on your system. It runs fine on my system.

  • Mostapha

Hi Mostapha,

Actually yes, I installed it. So, I’ll try to install it again.

thank you!


Interesting! Does Honeybee_Honeybee component turns orange once or is it fine?

It remains grey, like it would works. But then annual results files are empty.


Then can you go to the folder (C:\ladybug\SampleOfficeRoomAnnual\annualSimulation), open both .bat files (“C:\ladybug\SampleOfficeRoomAnnual\annualSimulation\SampleOfficeRoomAnnual_InitDS.bat” and “C:\ladybug\SampleOfficeRoomAnnual\annualSimulation\SampleOfficeRoomAnnual_0_DS.bat”) add the word “pause” at the end of the file and run them respectively?

We should be able to see the error then.



I got this. The I open the Command prompt but the raypath seems correct, even if there is a spelling mistake in the .bat file (rapypath instead of raypath).

What do you suggest?

Thank you,


Is it possible that the error is due to the Daysim 3.1 release?

Unfortunately, I cannot install Daysim 4.0 on Windows 7 professional 64 bit -strange -

thank you,


Solved it!

Thank you,


Great! I should have guessed that it was a version issue. Best of luck with your studies.

  • Mostapha

I’m sorry, but what actually solved this problem?



Installing Daysim 4.0

Hello Marco P,

could you explain how you installed Daysim 4.0 on Win x64? Wenn i run as administrator I see shortly the cmd window. In Control panel I see still only 3.1 version.

As in grasshopper when I run the daylight simulation I am getting the same error: Can´t find the results for the study in Grasshopper.

Any advice is appreciated!



Hi Niya, You should be able to install Daysim 4 with no problem on your machine. Are you sure that you download the right version? (http://daysim.ning.com/page/download)

I’m having the same issue and I’ve uninstalled/reinstalled everything. no idea what the issue is…I’m using the example annual file provided with Honeybee.

Hello all!

I am having the same issue of the component reporting “Can’t find the results for the study” even though the .ill files are actually appearing in the working directory. After digging quite deep into why this is happening, I have found out that the Honeybee function isTheStudyOver fails to report that the study is actually still running, meaning, that it returns “yes, it’s over” even though all the cmd windows are still open. And that happens because the proc.stdout simply does not contain any records.

An interesting point is that the same GH file runs fine on all computers in our studio except the one which has Windows 10 installed. Other than that I cannot find any differences between the different computers and why it would not run on one of them.

Does anybody know if win10 is actually the problem here or if I am missing some other reason for this problem?

Thank you!

Can you upload the case. I’m running W10 without any trouble so far.


Hi Rusne. To add to Abraham’s comment are you using the version on Food4Rhino or the latest version from github? One of the other users had a similar issue which was solved by updating the components.

For some reason we missed your issue here! sorry. I hope the issue is already solved.

Hi Abraham and Mostapha,

the problem does not depend on the case - even the simplest test does not work and even the most complex setup works on other computers. And yes, I have the latest version, updated it this morning, changed components on the canvas and still the same issue.
I’ve modified the code in isTheStudyOver like this to get more information printed:

and after running a test I get these things printed out:

(the cmd windows all open and running in the meantime).

As you can see the stdout does not get any line printed and the function returns after 0.3s without registering any activity…