HB Model to OSM - Severe Problem in interior solar distribution calculation (CHKBKS)

I am a relatively inexperienced modeller and need help.

When running either the “Run Annual Energy Recipe” or the “Run Annual Comfort Recipe” within my script the Model to OSMs (one in each section of script) report a “Severe Problem in interior solar distribution calculation (CHKBKS)”.

Adding a panel to the report to look at the issue, the data is some 21,000+ words of error message and is well beyond my understanding.

I am running a model which uses eight separate zones within the one building with an external shading object abutting one zone.

There are similar topics on similar error messages but I am yet to find an answer that resolves the problem in my case.

Assistance would be gratefully appreciated.

Note - as a new user I am apparently unable to upload attachments so I cannot share the Rhino and Grasshopper files.



Hey @GrantCross . Does your model have any concavity? Could you share more information about your model and errors?

Hello @hossein_nazari.

I am unable to upload anything to the forum as a new user however I think that the issue is that I have several model zones that have created non-convex zones due to their proximity with each other (sorry this would be easier if I could upload something to explain that).

The error has been resolved by only performing a “full exterior” calculation rather than a “full interior and exterior” thereby ignoring the interior solar distribution problem.

While I suspect that this has made my model less accurate - I have yet to find another solution.

Not sure that my response has helped you understand my problem and thus help me with it… however I do appreciate your interest in helping me.



@GrantCross I completely understand what is your problem. I have two solutions

  1. Set the shadow calculation method to PIXELCOUNTING ( the default is polygon…) and then check simulation
  2. If it doesnt work, split the non convetx zones into 2 or more zone and solve the adjacency between them as AIRWALL .
    I’m mostly sure your problem goes away.
    Let me know the result plz

@hossein_nazari thank for this.

I am trying the pixel counting suggestion now (the script is calculating). I already had the adjacency / airwall sorted as have learnt that issue in a previous model.

I will let you know as soon as the calculation has run.

1 Like

@hossein_nazari thank you so much for this.

The pixel counting setting seems to have resolved the issue.

Note - apologies for the rushed response to the previous message. it would have been perhaps more useful to note that I had fixed all the adjacency / airway situations I thought were pertinent but I still had some overlapping that I did not think were pertinent i.e I has some where I had zones of different lengths starting from the same base-point adjacent to each other (thereby some of the “common” wall was an airwall and some of the wall was not.

Regardless your suggestion on the pixel counting setting seems to be the answer I was looking for.

Thank you again for your help.



1 Like