HB model to osm

I tried to use the new ladybug tool , but my “hb model to osm” did not work correctly. As shown in the figure, when I tried to add the “measure” according to the prompt, I got a new error. Could you tell me what to do?

Thanks a lot for your responses.

Hey @huloujun ,

The measure component in your second image doesn’t have anything to do with the first error you experienced. It just that the measure under the hood of the ModelToOSM component, which translates Honeybee Models to OSM, failed to run correctly. I haven’t yet written good error-parsing functions for this type of failure yet so you can you can see exactly what went wrong if you open the run.log in the directory cited by the component error message in a text editor.

Here are some common reasons why the HB-to-OSM measure can fail:

  1. Your Rhino model is in millimeters but you thought that you were working in meters so your geometry is incredibly small.
  2. You have a white space in your username.

Thank you very much. The problem has been solved after the unit was corrected