HB Peak Loads Component Error

Hello -
My simulation shows all other results but the E+ Peak Loads does not work. it give the following error: 1. Solution exception:Expected Room. Got <class ‘honeybee.model.Model’>.

Any ideas on what could be happening?

The error panel is telling you what happened. It is expecting the rooms to be in the input and you are connecting the model.
-A.

1 Like

Abraham - Thanks for your quick response.
It does not work regardless what I connect it to.

Attached a snip of the component that I am using to connect to the Energy Plus component.

Even though it appears as solved, just to be sure, from your question it appears that it doesn’t. You need to connect the House Rooms output to the Annual Loads component.
-A.

Abraham -

It does not work even though I am connecting House Rooms.

Try 1:

Try 2:

I am facing the same issue , some body can help

@hosam @Yure

The first error (addressed by @AbrahamYezioro) was plugging in the HB Model when the input expected HB Rooms.

It didn’t work after you did that because of a second error in your script, which can be seen, partially in the screenshot:

image

It’s hard to make out, but looks like your DDY file path is empty. Get the correct file path and add it as text to your component. If that still doesn’t work, copy and paste the full error here (in addition to the screenshots) so its easier for us to debug.

1 Like

Thanks for following up here.

I am not sure what you mean by ‘get the right path and add it to the component’. But, I am adding a screenshot of the connections.

Error says: 1. Solution exception:Expected Room. Got <class ‘honeybee.model.Model’>.

As i wrote a while ago, you are connecting the model and not the rooms to the AnnualLoads component (the one in red on your image).
Just connect the rooms and it should work.
-A.

1 Like

@AbrahamYezioro, you’re right, but you can see in an earlier post that he used the HB Rooms as an input correctly (see screenshot below), and is getting another error due to his DDY file.

@Yure you keep making the same mistake: don’t use the HB Model as an input, use HB Rooms.

The “path” I’m referring to is the file path to the DDY file you’re using as an input into the _ddy_file parameter of the HB Peak Loads component. Can you add a text panel to the ddy_file output in the EPW component and share the output. Also, try selecting another weather file for your location. The DDY files should be part of the downloaded zip file, but maybe it’s missing for your current download.

image

1 Like

That’s right @SaeranVasanthakumar A couple of times it hapened to me that the ddy was “not good”.
For those cases (ad not only) i use the LB_EPWtoDDY component and locate it at the same folder as the EPW. It always work (for me).

-A.

1 Like

Hello @AbrahamYezioro and @SaeranVasanthakumar -

You were right. There was something wrong with the ddy. it’s been fixed. Thanks!!