HB Point-In-Time View-Based error

Hello all,

I’am learning to use HB, thus practicing with visualizations I tried with HB Point-In-Time View-Based (v1.4). After I changed boolean togge to true, few seconds later it shows me the following message:
Runtime error (PythonException): The recipe failed to run with the following summary:

Scheduled 15 tasks of which:
** 5 ran successfully:*

    • 1 AdjustSky(…)*
    • 1 ComputeViewSplitCount(…)*
    • 1 CreateOctree(…)*
    • 1 CreateRadFolder(…)*
    • 1 GenerateSky(…)*
      ** 1 failed:*
    • 1 SplitView(…)*
      ** 9 were left pending, among these:*
    • 2 were missing external dependencies:*
  •    - 1 PointInTimeViewRayTracing(...)*
  •    - 1 PointInTimeViewRayTracingLoop(...)*
    • 3 had failed dependencies:*
  •    - 1 MergeResults(...)*
  •    - 1 RayTracing(...)*
  •    - 1 _PointInTimeViewRayTracing_f677f6a5Orchestrator(...)*
    • 2 had missing dependencies:*
  •    - 1 LetPointInTimeViewFly(...)*
  •    - 1 _Main_f677f6a5Orchestrator(...)*
    • 2 was not granted run permission by the scheduler:*
  •    - 1 PointInTimeViewRayTracing(...)*
  •    - 1 PointInTimeViewRayTracingLoop(...)*

This progress looks :frowning: because there were failed tasks

Use the report_out attribute of recipe settings to see a full report.


What is this “1 failed: - 1 SplitView(…)” error and how can I solve it? is this the only ‘fatal’ error?.
Hope you coud give me a handwith this issue so I can get Point-In-Time View-Based images.

Many thanks,

@chris do you know what this issue could possible be? thanks

I have the same problem

1 Like

Hi @diegochile and @ma,

Are you able to share the logs file in the __logs__ folder?


I followed this route:

Please find attached the logs file:

logs.log (29.9 KB)


Thank you, @diegochile.

The username on your system has a space which throws an error. If you install the latest version of Ladybug Tools (1.5.0), I believe it should run fine. The easiest way is to use the single-click Pollination Grasshopper installer, which comes with a copy of Ladybug Tools. @chris put in a fix that will enable you to run with whitespace characters in your paths.



First, kudos to the LBT team for the 1.5.0 release!

I am experiencing some problems with PIT-VB too. In my case, however, it cannot create the radfolder (please see the log file attached:
logs.log (13.2 KB)

I checked for:

  1. blank spaces in the folder’s path (there is none).
  2. and also for permissions. I changed all folders to full permission, but they keep turning back to “read-only”. Could that be the problem? I tried several ways of changing that without success. Should I reinstall LBT?

Any advice is welcome! Thank you, Ticiana

Hi @Ticiana,

It looks like you inserted the view in view_filter_. If you want to filter the views you should insert only the view name. If you only have one view you should not filter the views and you can leave view_filter_ empty.

Thanks for the reply, Mikkel! It was, indeed, a much simpler mistake than I thought. It works now.

Hello Everyone and thank you for all your help and support.

Recently, I am facing the same problem:

I will share my log file hopefully someone can help me with what I am missing…
logs.log (34.3 KB)

Thank you in advance :blush:

[UPD#1] Running Rhino as Admin partially solves the problem, all types of view work…except Parallel(l) gave the same problem.

Im having the same issue…

Interesting thing I noticed is my Radiance version is older than @Ambrosinus’s version, even thought I just used the latest pollination rhino installer 2 days ago…

i dont always have the ability to run with admin rights, so I’m hoping there’s an alternative fix

Hi @jakechevrier,

Can you share the log file if you still have the issue?