HB-radiance ValueError('Invaild result folder (Vectorworks 2022)


I’m a Vectorworks user, and I’m trying to port the ladybug tool used in grasshopper so that it can be used in Vectorworks. (Description is in Japanese)

The wind rose, sun path, and solar radiation analysis went well, but when I was working on the light analysis, I ran into a problem.

I think it went well until the model creation of the room, but when I tried to run “HB Annual Daylight”, I got a ValueError and I can’t solve it.

I think it’s probably a problem with the directory specification, but what could be the cause? (The simulation folder in the user directory is partially written.)

(I also want to port Honeybee-energy and butterfly to vectorworks.)

vectorworks : ver 2022
python : ver3.9
ladybug&Honeybee : ver 1.6.0
radiance : ver 5.4a (2021-03-28)

After tracing various things, in the HB Annual Daylight node

project_folder = recipe.run(run_settings_, radiance_check=True, silent=silent)

When queenbee.exe starts when executing, it seems that an error occurs because the folder is not generated because it is interrupted with an error. (Since the results up to the middle are written in the simulation folder that saves the simulation results, it seems that recipe.run is working until the middle)

The error content in queenbee.exe is

Fatal Python error: ini_sys_streams: can’t initialize sys standard streams
Trackback (most recent call Tast):
File “D:\Program Files\VW2022\Python39\Lib\io.py”, line 54 , in
ImportError: cannot import name ‘open_code’ from ‘io’ (unknown location)

The version of ladyubug’s python seems to be 3.7.9, but the Vectorworks python I’m using is 3.9.
Probably, ‘open_code’ that has an error seems to be compatible with python3.8, so when executing queenbee.exe, an error occurred because io of vectorworks was called from python3.7.9 I feel like

I don’t know if it’s okay to ask here, but is there a way to upgrade ladybug’s python to 3.8, or a way to avoid calling vectorworks’ io, or prepare an alternative function for open_case? (I’m not very familiar with python’s underlying system.)

Was self resolved.
By specifying the path to vectorworks’ python in honeybee’s cinfig, I was able to successfully display the results.

However, writing the path ( “python_exe_path”: “D:/Program Files/VW2022/Python39/python.exe” ) in honeybee’s config.json didn’t work, so I wrote it directly in config.py.

Any advice on how to use config.json would be greatly appreciated.
(Because there is ladybug-tool of GH and ladybug-related files installed for vectorworks on the PC, there is a possibility that some kind of problem has occurred.)

PS: Please point out if there are any problems with personally creating and publishing tools with vectorworks marionette nodes referring to grasshopper’s ladybug-tool.