HB Read Custom Result

Hi @Chris,

How can I use the HB read custum result component?
When I use the HB read result dictionary and attach the outcomes to the HB read Custom Result component, I get no results.

Are you requesting any of those outputs in HB simulation output?

Hi @devang,

The first two would be nice.

I believe @devang’s question is if you are asking in the code to calculate those outputs. If you are not you can’t get them, even though they appear in the RDD file (as potential outputs).
I guess you can do it using the ‘additional strings’ option.



Okay, now I get it. That is why they are not appearing.
I have to add them to the simulation output request.
Thank you for the information.

FYI, you can use the “HB Custom Simulation Output” component to request whatever outputs yu want from the simulation:

Additional strings are also an option as @AbrahamYezioro suggests.

1 Like

Much better, of course. Nice!!

Hi @chris ,

When I use the read custom result component, the values that I have obtained from the component are different from the values I have obtained from de SQL database. In this example I have asked for the monthly “zone windows total transmitted solar radiation energy” and the values (kWh) obtained from the component for a zone are:

(8 months witn 0 !!)

And from the sql file (J):


Thank you Chris,

Hi @BestiaParda,

It looks like you are interpreting hourly values as monthly values.
So these zero values are quite logical. At night there is no sun.
I can not see how you structured your data, but I think this is the isue.

Hi @Erikbeeren,
The data after the calculation seems to be ok, I can see 12 values for each month in the database.

But when I use the read result component seems that the monthly values are changed to hourly values.
In fact, the HB color room component get the same wrong data from the Read Custom Result component :

I think that the Read Custom Result component is getting the data as hourly but I dont know how to change the data to monthly in the component.

Thank you for your help @Erikbeeren

Hi @chris, @Erikbeeren,

I have run the same simulation and I asked for the “Daily Results”. In the SQL file I can find the 365 values but when I try to use the Read Custom Result Component the first 244 values are 0.

Thank you

Hi @BestiaParda,

Why don’t you use the read face result component?


Hi @Erikbeeren,

I’m trying to show the Window Transmitted Solar Radiation Energy. The face result component shows only the heat gain and the heat loss.

@BestiaParda ,

I am not able to recreate the issue like what you are showing. The Window Transmitted Energy looks perfectly fine to me when I request it on a Monthly basis:

custom_result_test.gh (95.1 KB)

Do you want to upload a file with the minimum that is needed to recreate the issue?

Hi @chris,

The problem is the HB Load Measure Component. When I run your example with this component the results were wrong. You can see here the results:

I have uploaded your example with the HB Load Measure.
I have re-run my model without the HB Load Measure and the results are correct.

custom_result_test_R2.gh (106.5 KB)

Thank you very much for your help!!

@BestiaParda ,

When you select a measure that edits the requested EnergyPlus outputs of the OSM, then you should not be surprised by weird behavior in the Honeybee results. Try seeing if you can turn off any reports related to zone solar gain on the Measure arguments and see if that fixes it. Or you can edit the code in the measure to not request the same EnergyPlus output that you’re requesting from the Honeybee end. Or you can just request the hourly solar gain (which it seems like the measure is trying to do) and post-process the results into monthly data using the “LB Time Interval Operation” component.

At the end of the day, the purpose of measures is to give you unlimited freedom to change anything that you want about the simulation, even when it’s not supported by honeybee or following the rules that honeybee abides by. So you’re taking responsibility into your own hands when you choose to use measures.