Hiding Queenbee.exe

Hi All,

I’ve developed quite a nice front end Rhino Grasshopper routine using Human UI to pick and select grids and run some analysis in HB Radiance. When the calcs run, the Queenbee.exe terminal window pops up and runs the calcs. I’d love to silence this or always have it running behind the windows if possible so the presentation window is always visible. Does anyone have any solutions for this they could share?


Hi @ladyloo,

Instead of setting _run to True you can set it to the integer 2. Setting it to 1 is same as True, and 0 is False.


1 Like

Hey Mikkel. Thanks for the reply. That looked like the perfect solution!. BUT it doesn’t seem to work. Still getting the terminal window pop up. I’m using the SkyView recipe. Do you know why that isn’t working for that one?

Looking into the recipe, I’ve changed this line:

project_folder = recipe.run(run_settings_, radiance_check=True)

into these:

silent = True if _run > 1 else False
project_folder = recipe.run(run_settings_, radiance_check=True, silent=silent)

to match the DF recipe. Unfortunately still not running in “silent”

FYI, @ladyloo ,

@mikkel added a fix for this case, which was just merged into the code base:

It seems that “Sky View” was the only recipe that we forgot to implement the “silent” option with.

In any event, you can get the updated component with the LB Versioner on your end in 20 minutes or so.

Hi Chris and @mikkel,

Absolutely brilliant. Thank you very much!


Good stuff, but maybe it should be clearer for new users, maybe a silent parameter for run_settings