Honeybee-energy simulate model Failed to run OpenStudio CLI

I want to export a HBJSON file exported from the Revit Pollination plug in into a Radiance project and an IDF file.

I found that the best way to achieve this is through the Honeybee energy CLI
More specifically:
honeybee-energy simulate model [OPTIONS] MODEL_FILE EPW_FILE

I have been trying a number of combinations and changes to the model but I keep getting the following error:

Message: "Model simulation failed.\nFailed to run OpenStudio CLI:\nundefined method `validate' for #<Hash:0x000001df16c31f30>"
Arguments: ()
honeybee_energy.cli.simulate - ERROR - Model simulation failed.
Failed to run OpenStudio CLI:

Exception: Failed to run OpenStudio CLI:
undefined method `validate' for #<Hash:0x000001845a0fe0a8>

I am using python 3.10, EnergyPlusV23-1-0 and the latest version of honeybee-energy library. This keeps happening with any model I have tried. The odd thing is that it used to work last year, but now I keep getting a validate hash error all the time.

Does anyone know if I am doing something wrong?

Hi @adalbertogc ,

I sense that the version of honeybee-energy that you have installed to your system Python is very old. At the very least, the version of the honeybee-openstudio gem that is being used to translate the model to OpenStudio is from a very long time ago (perhaps it’s some old installation that you forgot about in your C:\User\[USERNAME]\ladybug_tools folder).

I recommend updating all of your LBT core Python libraries by running the following from command line:

pip install lbt-dragonfly -U

That should update everything so that honeybee-energy will find a newer version of the honeybee-openstudio gem on your machine if it exists.

If you still have problems after that, you should install the latest version of Ladybug Tools using the Pollination Grasshopper single-click installer. That will ensure that you have the latest version of the honeybee-openstudio gem installed along with a compatible version of OpenStudio.

1 Like

I followed the recommened steps: I ran pip install lbt-dragonfly -U and I was getting a different error related to initialization but then after intaller the pollination grasshopper plug in, it worked honky dory. Thanks very much!

1 Like