Honeybee energy simulation error

Hi guys,

I am learning to use honeybee by following Chris’ youtube tutorial videos (they are very wonderful tutorials, thank you Chris!). When I trying to run energy simulation on honeybee, weird things happens:

  1. the readEPResult component works, but there are no outputs on cooling, thermal loads and thermal load balance data. From the tutorial video i guess these data should be in outputs;

  2. and there are no html report created in RunEnergySimulation Component;

  3. the readEPSrfResult component didn’t work and the error is as follows:

" Your simulation probably did not run correctly.
Check the report out of the Run Simulation component to see what severe or fatal errors happened in the simulation.
If there are no severe or fatal errors, the issue could just be that there is .eio file adjacent to the .csv _resultFileAddress.
Check the folder of the file address you are plugging into this component and make sure that there is both a .csv and .eio file in the folder. "

I look into the folder and I sure the .csv and .eio file are there.

I think got everything the latest version, so i wonder what is wrong?

Thank you very much in advance!


test-1.3dm (103 KB)
test-1.gh (593 KB)
CHN_Guangdong_Guangzhou.592870_CSWD.epw (1.69 MB)

Is it a similar issue to this one?


Thanks for your reply, Mostapha! yes, it seems quite similar to my first problem.

There is a discussion here: https://github.com/ladybug-tools/honeybee/issues/132

ah, ok, I will wait for the updated version.

Btw, may I know if you have any suggestions about the problem 2 & 3? Especially problem 3. I tried to find answers from the other discussions in the forum but I found that there are still no final solutions yet.

similar disscussions:




Hi, Mostapha,

I think my 2 & 3 problems were solved. I used the “updateHoneybee” component before , but I just set true to “updateThisFile”. This time I try to set true to “updateAllUObjects” and it works.

Anyway, thank you very much!