Honeybee[+] Failed to load results from empty file - Annual simulation

I get the following error message when executing annual simulations with Honeybee[+]. The error message was produced while running a sample file. Am I missing something or is this an installation issue? I am able to run daylight factor simulations without any errors.

"Loading the results from result files.
Runtime error (Exception): Failed to load the results form an empty file: c:\ladybug\honeybee_005\gridbased_annual\result\sun…scene…default.ill
Double check inputs and outputs and make sure everything is run correctly.


  • line 695, in annual_sunlight_exposure, “C:\Users\Lenovo\AppData\Roaming\McNeel\Rhinoceros\6.0\scripts\honeybee\radiance\analysisgrid.py”*
  • line 60, in script"*
1 Like

I am getting this same issue too… But I’m not sure what the reason is… I cant find the error.txt file from the results directory as well. Hope someone can help

Was there any solution to this? I am getting the same problem.

Me too exact same problem!

The most recent update on food4rhino works. Updating worked for me. I did a complete re-install.

I also reinstalled but the problem still remains.

I am also getting the same error. I have installed the latest files from food4rhino.
Any solution to this?

Did you remove any previous versions of LB/HB components?

I have removed the previous versions of LB/HB components.
I have updated my legacy plugins (downloaded from food4rhino). Then, installed the latest version of honeybee[+] plugin from food4rhino. The problem still persists.

I further updated my honeybee+ plugins using honeybeeplus installer. Still, I am unable to run any of the honeybee[+] sample files.

I am getting the following error while running all the grid-based analysis (daylight factor, point in time analysis, annual daylight & annual daylight analysis):
1. Solution exception:Failed to load the results form an empty file: c:\ladybug\hbp_sample_file\daylightfactor\result\hbp_sample_file.ill
Double check inputs and outputs and make sure everything is run correctly.

Any assistance you can provide would be greatly appreciated.
Thanks in advance!

Hi @Anushma. Can you share your gh script to check

Hi @Asisnath
Thank you for the prompt reply!
I have attached the gh script. It is a modified version of the sample grid-based annual daylight simulation script shared on Github. I have also tried running other sample files but I am getting error in all of them.
Please help me out.
sDA_ASE1.gh (69.1 KB)

@Anushma . It ran fine on my end. I only updated the script with ladybug update file component. Try this updated file.sDA_ASE1.gh (71.6 KB)

The problem was with the radiance. I had radiance-5.2.0 installed in my system.
Updated it to radiance 5.2.2 from this link https://github.com/NREL/Radiance/releases/tag/5.2.2
The script is working fine now.
Thanks for looking after!

That is great. But I recommend switching to radiance 5.3 stable relaease as all the new LBT are optimised with this .

1 Like

Thank you for the information. I will install radiance 5.3 for my work.

hello @Anushma
Was the problem solved only with the radiance update? Or did you make other changes?

I updated the radiance but still the problem was not solved.

Hi @Aliarch

The problem was resolved after updating the radiance. I didn’t make any other changes in the script.
I hope you have installed radiance 5.3 for your working.

1 Like