Honeybee (input_geo is not a closed volume)

Good evening,
I’m experiencing an error of input_geo is not a closed volume, i modeled the whole model in grasshopper then with a hole in the building (but its surrounding is closed) and i want to calculate the daylight on the different generated floors (it is already read that it is about 16 room), the problem is when the hole is straight lines there is no warnings, but if it is curved or SubD this error comes out, how can i solve this ?

  • i can’t upload because i’m a new user:(
1 Like

Hi @Mohamed.AbdelAzim ,

This can happen sometimes in Face-by-Face workflows where the methods that planarize things for the simulation engines don’t know exactly how the other Faces of the Room were planarized.

But, if you have a closed solid Brep and you use the HB Room from Solid workflow, the solidity should be preserved between the input Brep and the resulting Honeybee Room. Using the HB Planarize Brep component can also give you some insight into how these planarization routines work.

thank you @chris for the reply,
i checked what you said but it didn’t work although i tried many mesh settings, after meshing the surface some surfaces isn’t closed causing the error i think, i tried other modelling workflows but still didn’t work, what workflow should i go with in modelling the rooms?

I’m able now to upload the file, so if u can check it i would be thankful
honeybee geometry.gh (25.0 KB)