Honeybee Installation problem

Hi everybody,

I am trying to install Ladybug and Honeybee on a new system.
I followed the instruction and installed all the necessary software. but still Honeybee does not work properly and I get errors.
Would somebody please help me.
I attached screenshots of the errors here.
Thank you very much in advance.


1 Like

Please check this one. I think it is a similar issue.

Thank you very much devang,
As I understood from that post, I have to use another internet connection to install Honeybee and Ladybug, right?

HoneybeeResources.zip (2.2 MB)

Please manually download this file, and unzip it to “C:\ladybug” folder.

Thank you very much MingboPeng,
There was not such a folder ‘ladybug’ in my C drive.
First I copied the files you sent in the ladybug folder where I found in my C drive “C:\Users\Saeed\AppData\Roaming\Ladybug” and it did not work. Then I created a ‘ladybug’ folder in the C drive and copied the files in there and it did not work either.
Any idea where I am doing wrong?

Did you disable/enable the component after copying the files?

Thank you Mostafa,
If you mean disable/enable by right-clicking on the component; No, I did not, I did after you mentioned, but nothing has changed.
To make it clear, I attached the screenshot.


This is my suggestion for debugging the workflow.

Why this error is happening?

Honeybee uses a download as needed process of installation. This means it doesn’t install everything at once which gives you a better user experience when you use it by not downloading a lot of stuff that you won’t need or use in your workflows. That being said there are a number of libraries that are critical for Honeybee to run including OpenStudio master template files which Honeybee uses to load the schedules, materials, constructions and templates.

These files are hosted on GitHub under resources folder and each time the you drop the honeybee_honeybee component on canvas it checks to ensure these resources are available, otherwise it tries to download them from GitHub.

Some of the countries/networks have partially blocked access to GitHub and once Honeybee tries to download them it fails to download them successfully. This is why you get the error.

How can you solve this issue?

As @MingboPeng mentioned you can address this issue by downloading them manually and copying them to Honeybee’s working directory. To find the working directory check the output of ladybug_ladybug component. For most of the users who don’t have full permission to C drive it will be %USERPROFILE%\AppData\Roaming\Ladybug otherwise it will be C:\Ladybug. If you create the folder manually with full permissions Ladybug will find and picks it as the working directory.

Now to solve your problem check the working directory, copy the files manually to the folder, and restart ladybug and honeybee. This should solve the issue. If it didn’t please report the full error message as you did in your original post.

Thanks a lot again Mostapha,
I did what you said (screenshot 01). I downloaded and copied all the files and folders in the both paths C:\ladybug and also in the C:\Users\Saeed\AppData\Roaming\Ladybug. But still the same problem. (screenshot 02).
I used Ladybug and Honeybee several times on my old laptop, and now I just changed my laptop, the country and the network are the same as before, I don’t know why it happens!
Thank you very much in advance for your time and support.

I checked the source code and it’s actually happening when Honeybee tries to create a folder inside OpenStudio installation folder. In your case Honeybee is failing to sort the installation folder for OpenStudio and that probably is the reason of the failure. @chris should be able to tell you why do you need this folder under OpenStudio folder. For now I think you can just comment them out by adding a # in front of these two lines.

Hello @Saeed390 ,

Sorry for being late to this issue. The reason why that folder is needed is that OpenStudio stopped distributing the full version of E+ a few months ago (now, they only distribute the parts of E+ that are being actively used by the OpenStudio interface). However, Honeybee relies on the full version of E+ so we had to download in the background the E+ files that HB uses but OpenStudio no longer distributes.

If you copy the files from here, unzip the file and paste everything into C:\openstudio-2.3.0\EnergyPlus\PostProcess, that should get it to work.

All of this said, I can’t wrap my head around why the sorting of OpenStudio folders is failing. Can you show me where you installed OpenStudio and what version you are using?


Thank you very much @mostapha
I did what you said and checked them several times.
Then I tried to test to see if it works or not, but still it does not work.
I attached the screenshots which shows what I did.

Thank you very much @chris
I downloaded the folder and copied it in the address you mentioned.
But still does not work!
I use the last version of Openstudio (I uninstalled and reinstalled it today again).
It has been installed in the default folder of the installation procedure.
I attached the screenshots which show what I did.

Ah, I forgot one last thing. Download this file:

and copy it into C:\openstudio-2.3.0\EnergyPlus.

Then it should work without any issues.

Hi @chris
I downloaded the file and copied it in C:\openstudio-2.3.0\EnergyPlus
still get this error

Is this issue resolved? This is the same error message at the same line which probably means you haven’t commented them out.

Dear @mostapha,
No, in the last screenshot I didn’t change anything in the source code because I assumed @chris wanted to solve the problem fundamentally, and I just wanted to show what happened after his suggestions.
Now, I commented the two lines in the code as you said and it works. problem solved for me!
I have to say thank you very much for your great support. You are awesome and I appreciate your work a lot.
I wish the best and a great time for you.

1 Like

how can I install Daysim

Hi,Please refer to this post https://github.com/ladybug-tools/ladybug-legacy/wiki/Installation-Instructions.

1 Like