Honeybee_Write Therm File - error regarding empty path name

I’m new to Grasshopper, and I’m trying to learn how to run a therm model using the Honeybee plugin. To try to understand how a file runs, I’m looking at the Parametric therm model example file from Hydra (at the link below). When I try to run the Write Therm File component, I get an error that says “solution exception: empty path name is not legal." Is this in reference to the working directory and/or file name? I have inputs for both of these without spaces or underscores in the names. I have Therm version 7.7.1.0 installed on my computer, do I need a specific version to run the plugin in Honeybee?


Thank you, any help would be appreciated!

http://hydrashare.github.io/hydra/viewer?owner=chriswmackey&fork=hydra_2&id=Parametric_THERM_Model&slide=0&scale=1&offset=0,0

Mostly, this is because of the space in the file path you are providing. Remove that and this error should go away

I already checked and I just rechecked again, there’s no spaces or underscores in the file path. The directory name is “C:\AE597” with no spaces, and the filepath name has no spaces either. I’ve also tried removing the file path and file name inputs since the Component instructions said those were optional. I did get a .thmx file that was written to my file path, but I’m not sure how to use it, and therm won’t read the file.

i am having the same issues now.

please help.

I didnt specify the file path as it is optional

For me, I eventually found that the issue was related to the version of Therm I had installed. Honeybee only works with Therm version 7.6, not the newest version, which is 7.7. Once I installed 7.6, it worked right away. Also, I was able to keep both versions of Therm installed without it causing any issues.

2 Likes

this one worked for me.

the real reason is this.

i installed 7.6. its running fine.

thanks

thanks a lot ,it’s very useful