How to Conduct a Daylight Analysis Considering Artificial Lighting?


This might be a silly question.
I’m trying to conduct a daylight analysis that considers artificial lighting, but I’m not having much success.

I have used the IES Luminaire component to set up the artificial lighting and connected it to the additionalRadFiles input of the RunDaylightAnalysis component. The analysis runs without errors, but the results don’t seem to reflect the artificial lighting settings.

I have successfully conducted an analysis with natural light only.

I’m not sure what adjustments need to be made, and I would appreciate any advice you can provide.

Is there something wrong with the way I connected the components in the purple section?

Hi @kashima You should use climate-based sky for this simulation.And decrease the range of legend to 0-500lux.

Hi Mr.minggangyyin.
Thank you so much for answering my question.

I tried changing the sky settings to “GenClimateBasedSky” compornent and the range to 0-500, but it didn’t work out well.

There are no error messages, but the lighting is not being detected. I tried using reliable IES files.

Is there anything else you think might be missing?

@kashima Please check the ies2rad component.As the screenshot, this componet has a warning.

Thank you for your response.

The warning with that component was minor and I was able to resolve it quickly.
However, I am still having trouble getting the artificial lighting settings to work.

In this Rhino model, there are a room with natural light coming in and a room with only artificial lighting. However, the rooms with only artificial lighting do not seem to detect any light.

Sorry to keep asking, but please bear with me.

@kashima Please upload your rhino and grasshopper file for next discussion.

I apologize for the inconvenience and Thank you for your patience.
I have attached IES file used.

test02.3dm (74.4 KB) (575.5 KB)
0054b969db1d9f70197a0328f8512e82.ies (1.4 KB)

EPW data is too large to send, so I used the data from this website:

@kashima It has a little mistake about your grasshopper. You should set True to Write_Rad.Then the result showed fine.

1 Like

Oh, I understand now.
That was indeed a small mistake. But I couldn’t have noticed it on my own.

Thanks to your advice, it worked well.

Thank you so much for your time and consideration!