How to make the airflow result using Butterfly more smooth?

Recently, I have doubt the meshing workflow of Butterfly. The surface level、the refinement level and surfaceFeatureExtract is too complex for the beginner.

So I just compared different setting to analysis.

Case A is building surface setting the level to (3,5). nCellsBetweenLevels =6
Case B is building surface setting the level to (3,5), nCellsBetweenLevels =3
Case C is with refinement region and building surface setting the level to (3,5), nCellsBetweenLevels =3

Case A

Case B

Case C

Comparing the Case B and Case C, the region near the building is refinement region.The velocity is smooth in it. But the farther region is still not smooth.

And sometime the global refine level is not effective for meshing.

So guys, Could you tell me how to set the surface level, nCellsBetweenLevels and the refinement region level for a smooth result?

Have you used the new wind tunnel grading component? It automates the process of calculating blockMesh? That should help you with putting together a smoother mesh.

The 3 cases is using old version.Thanks for your message,I will try it update to new version.

Hi @minggangyin, In case you haven’t updated yet then you might want to wait a little bit more. I’m caught up with other projects and haven’t had the chance to fully test the new butterfly after the changes.

@TheodorosGalanos can share his insight which is how the auto-grading component also works.

@mostapha OK,I got it. Thanks for your reply. I will keep watching this issue.

@mostapha @TheodorosGalanos Sorry for discover the new component -Wind tunnel auto grading.
It worked very good for blockMesh and the snappyHexMesh. And the result showed more smoothly than ever.

Thanks for reminding me.

Here are some snapshots for sharing:


I can’t find this componants (Wind tunnel auto grading) : what should I typed in GH to find it?


@ebifbezif Update the butterfly to the newest version , you will get the grading component.

1 Like

Hello Minggangyin
Thank you for this post, how did you control the settings for the grading component? what do you input into the xGrading, yGrading and zGrading? did you leave them as default to get this result?

i always get wrong side of refinement area, how to adjust refinement region into our object?

Is this the picture generated by grasshopper? How to make the falsecolor map smooth like this instead of jagged falsecolor map in grasshopper?

I used ParaView for the CFD result post-processing. It can generated smooth color based the data. You can try it.