"If Envimet is not in default unit 'C:' connect the installation folder" error

Hello everyone,

I’ve been working in a simple exercise, just to get to know how envimet works with grasshopper.
Everything seems ok, the components do show any warning messages and when I try to run the simulation, at first, it works, but after a while, when the main module of envimet is started, I get the message: “If Envimet is not in default unit ‘C:’ connect the installation folder.” Then the simulation stops, the window shows the message “Press any key to continue”, and once I do the window just closes.

The same message appears when I connect the Full Forcing settings component to the component where the simulation settings are established.

I don’t understand. Envimet IS in default unit ‘C:’. Because of these errors I even tried to use the Installation folder component with the directory to where envimet is (C:\ENVImet445) but it doesn’t really make any difference. Does anyone know what problem is this and how can I fix it?

Thank you,

Hello, have you solved this problem? I also encountered the same problem and don’t know how to deal with it.

FYI, @AntonelloDiNunzio has released a new plugin called Morpho, which is specifically devoted to writing and simulating ENVI-MET files from Grasshopper:

So I would recommend using that since dragonfly-legacy is deprecated at this point.

I have the same problem but it is while I am useing morpho. I have an average size model. The simulation starts running at first and evaluate flow calculation completely but after that the error or message occures:

[“If Envimet is not in default unit ‘C:’ connect the installation folder” error]