Illogical results when using "HB Dump Compressed Objects" on large models

Hello everyone,

I’m currently modeling a large site and trying to compare the irradiation values on several points with or without some buildings and trees.
For this, I’ve defined 4 different simulations :
-Model 1 : Average weather/With trees/Without Octogonal Buildings (OB)
-Model 2 : Average weather/With trees/Without Octogonal Buildings (OB)
-Model 3 : Sunny weather/Without trees/Without Octogonal Buildings (OB)
-Model 4 : Sunny weather/Without trees/With Octogonal Buildings (OB)
The problem encountered is that my geometries are quite complex and thus generated first a "Solution exception:The recipe failed to run with the following summary:

  • 1 failed:
    • 1 CreateRadFolder(…)" error when I tried tu run it directly. After searching how to solve this error, I found this post (Large radiance models: Memory errors and levels of simplifications HB-R - #11 by chris), where the “HB Dump Compressed Objects” was given. This indeed solved my problem. However, I realised the simulation was giving illogical results after that, such as small or negative difference of irradiation between a simulation without buildings and a simulation with buildings, even though the surface investigated was clearly in the shadows of the buildings.
      I managed to run one of the simulation (without shades) without the component and the difference was much more consistent, but I really doubt the other results to be true.
      Is it possible that my model still is too large after the “HB Dump Compressed Objects” component? I would really appreciate some insight/solution on this matter.
      My files can be found there : WeTransfer - Send Large Files & Share Photos Online - Up to 2GB Free

Thanks in advance!

UPDATE : It seems that "HB Dump Compressed Objects has nothing to do with the problem since I had the same problem without using it. I managed twice to have consistent results. The first time I deleted the other parallel models, deleted the .pkl files in my computer and relaunched Rhino. After a few simulations, the problem reappeared and the first method didn’t solved the problem. So I tried quite a bunch of other things, and finally deleted my rhino surface used for the grid and drew it again, and it worked. Unfortunately it failed again after some simulations, and didn’t work after that. Any suggestion?

@chris @mostapha or any other Ladybug tools’ boss, I think I definitely need your help since I spent two days trying to solve the problem, without any real success… :smiling_face_with_tear:

Hi @ThiSol,

I saw your post yesterday but I didn’t have the information needed to help you. Can you share the log folder after running the study? It is a subdirectory inside the study folder.

Hi @mostapha !

Thank you for your quick reply and sorry for the lack of this log folder in ny first posts, I’m quite new on these topics.
You should find the logs files attached, I hope it’s the good ones (found under study folder-> annual irradiance. The err.log is empty.
logs.cfg (1.0 KB)
logs.log (84.0 KB)
status.json (23.9 KB)

Here is more information about the problem : the irradiance results are almost the same (only difference is some tenths in the results, caused in my opinion by uncertainties of calculation), whether you put your sensors in the sun or behind a big shading building. The levels of irradiance seem match a shaded situation (around 100-125 W/m2 at noon the 21/03, while the global horizontal irradiation of the weather file is 500-600).

Thanks in advance, I’m looking forward your analysis!

1 Like

Hello everyone!

Sorry to be so insistent, but has somebody found the origin of this bug? :sweat_smile: @mostapha @chris ?
The thing is I need this simulation in order to solve an urgent matter and I’m quite stuck by this bug for the moment :sob:.
Thanks for your time and tips.

Hi @ThiSol, Sorry for the delayed response. Based on the logs everything has run successfully. Are you sure that you are sharing the correct logs here?

Hello @mostapha,

Thanks for investigating the question.
I finally found the problems :

  1. My sensors were facing downward since I defined my sensor area by first drawing (clockwise) 2 polylines, and then creating a surface between the two in Rhino. Thanks for pointing me the logs file, it allowed me to discover and investigate the .pts files, where I found this first problem.
  2. Apparently, running several HB radiance simulations in parallel with the same False start toggle boolean seems to disturb HB. I therefore separated and ran the simulations one by one.
    Thanks a lot for your time and insight!
1 Like