Image-based simulation results in dotted picture on higher settings

Hi

I have a problem when doing image-based calculations in Honeybee plus.
When rendering on high settings the image is filled with dots.
When rendering on lower settings there are still some dots, but much less.

I’m using Accellerad for rpict.
I’m also running pcond -h+ and ra-tiff on the image, but it doesn’t change the problem with the dots.


image

Turns out it has to do with the irradiance cache in rpict.

From Accelerad’s website:

Patchy or blotchy rendering
Patchy or blotchy rendering may occur if the irradiance cache provides insufficient coverage of the scene. This algorithm may occasionally to undersample diffuse lighting in many-bounce paths. The size of the irradiance cache in accelerad_rtrace or accelerad_rpict is fixed by the -ac parameter. To increase ambient coverage, increase the -ac or -aa parameter value, or decrease the -ar argument. To turn off irradiance caching, set the ambient accuracy -aa to zero.

Setting -aa to 1.0 removed the dots.

1 Like