Import/Export gbXML

Hello everyone,

I’m currently working with people using DesignBuilder. To share files, I proposed to use the gbXML format that seems well appropriate. But I have some issue with HoneyBee and its gbXML exporter.

First of all, it looks like there are two different gbXML exporter. The first one that export OS models to gbXML, found in the 10th tab. The second one, Grizzly Bear, in the 12th tab, found with this webpage.

What are the main differences between these two components ? Is there one that is old and that I should’nt use ?

So I’m using GrizzlyBear. I’ve installed the dependancies files in C:\gbXML. (By the way, the link in the component is dead, I’ve found a proper link on the old forum). But now I have two warnings :

- 2. Failed to find in the Honeybee schedule library. This seems to be a bit old issue because it has already been reported in 2014 but I couldn’t understand how to fix it.
- 1. Failed to find SECONDARYSCHOOL CLGSETP SETBK 50.0 SETPT 50.0 in the Honeybee schedule library. This is a schedule made by the setpoint component I suppose. Why is there a problem with that specific schedule ?
At the end, the ouptut once opened in designBuilder shows only the geometry, there are no composition or schedule in the file…

So if anyone have uptodate informations on what is possible to do as import/export gbXML, that would be very nice. Thanks for your help all !

Grizzly Bear was developed as a single component and was more of a proof of concept. It only exports HB to gbXML and doesn’t import gbXML.

The newer version is built on top of OpenStudio API and will replace Grizzly Bear. It is capable of both importing and exporting gbXML, and since it is build on top of OpenStudio API we know that there will be a continuous support for development and adding new features. I suggest you to use this one. Did you get a chance to give it a try?

With some geometries I had some parts missing and in most cases there were no informations with the geometry …

What is the version of OpenStudio that you are currently using? We can report that to the OpenStudio team and help them to fix it. Meanwhile I can take a look to GB and see how can we help you there.

Sorry for the late answer,
HoneyBee Viiiiz tells me : “Found installation of openstudio-2.5.0.” (I’ve noticed that there is now a 2.6, I’m downloading it currently)

So basically here is a geometry I’ve been working on and that I cannot achieve to export then open properly neither on DesignBuilder nor on LadyBug Spider. GBXMLexport (249.3 KB)
There are roofs between floors, no windows, and I cannot find my constructions. Whereas this works in GH, before exporting.

Edit : So I’ve updated LB, HB and openstudio. But the issue is still the same …

1 Like

I just noticed that I’ve forget to attach my GH file. So here it is, normally it’s properly internalised.
GBXML (768.3 KB)

Btw, I’ve been wondering if these issues where linked to Rhino tolerance/unit (which is often the case with adjacencies, boolean operations, or face recognition). So I made a few test but this doesn’t change anything.

Hi @EmmanuelR, Sorry for the very late reply. Can it because you are using a button and not a toggle? Did you try to use a Boolean Toggle instead?


I can successfully export the model to gbXML and visualize them in gbXML editor.

Greetings all

On a similar note, I am also trying to export Grasshopper model to gbXML in order to revalidate it in DesignBuilder.

I have read the instructions, connected a toggle instead of a button but no file shows up in the folder. I have made sure all exports are in the same C drive yet no file is created. The node says the export was successful and yet nothing shows up.

Do you have any idea why this could be? It could be something super simple yet I cant find out why. (Openstudio 2.9.1) (Honeybee export Ver 0.0.64) Is this node still supported?

Any suggestion would be greatly appreciated. Thanks :slight_smile:


Have you tried add the full filepath to the gbxml (i.e R:\ffortich\results\gbxml\my_model.gbxml)?

And the component should work, I’ve used it myself with OpenStudio 2.7. I haven’t tested 2.9 myself, but I know it includes a number of bug fixes the NREL team made to the gbxml importer (I reported them to the team!), so it’s the better version to use.


Sorry for the late response Saeran! Crazy times. It did work when I put the whole file name! Really simple solution! Thank you!

For future references, another recommendation is that when exported it comes out as gbXML, while Design builder has the import option (BIM model) that only reads xml, therefore I had to manually modify the file type to xml only.

Then it worked and opened the geometry perfectly.

There is one more thing. From what I have been looking online, it appears hard to do, and its to import also the ladybug properties. In other words, the materials, occupancy schedules, ect

For example, although the construction names are imported from the gbXML, looking at their properties in the edit tab, their U-value are actually different from what was specified in the original Grasshopper file. Therefore these values would have to be set up again.

Likewise, the occupancy, occupancy schedules, HVAC system seem not to be translated into the model. If anyone has solved this I would be very happy to know. :slight_smile:

If not, I guess it would be have to updated manually, which is doable but not ideal :).

Thanks again!


GbXML won’t translate HVAC systems. And I’m fuzzy on whether it does schedules and loads so hopefully someone else can come here and confirm it for us.

GbXML does translate construction and material properties, and this was exactly the error that I reported to the OpenStudio team, a while back. They did fix it, and it should be working in OpenStudio 2.9.

Are you able to open this file in the OpenStudio app, and make modifications to the U-values, and then export/import the gbXML to see if it makes a change? If yo can isolate the issue to OpenStudio, then I would post the error on and see if the OpenStudio devs have further advice.


Thank you for your help Saeran!