Import gbXML file generated from ARCHICAD

Oh! I found it in the previous answers! Sorry I asked.

Hi Noora,
it’s still another problems, when u try to export from Archicad. I use Spider (Ladybug tool) to check and visualise the xml building, but sometimes it doens’nt export the whole building… for example it miss overhings sometimes it miss some walls and roofs …
Any suggestion it’s welcome.
Merci beaucoup.
Thank u

Hi Aziz,

Yes, I see… I exported ArchiCAD to xml and I miss windows.

I’m new in ladybug and honeybee, I’d like to do daylight analysis and I wonder what’s the best way to work with Archicad files?

I tried AC-GH live connection, but the problem is that it is very difficult to choose openings (windows and doors). You can choose the surface of walls, roof, floor, etc. but not the openings!

I’ve also tried to export Archicad to rhino, but it comes with the wall thicknesses, and it is quite time consuming to clean the file, choose the right surfaces, etc… especially in complex models.

Does anyone have any suggestions on how to work with acrchiad files?

@Aziz.BOUKARA and @Noora you should post the issues with Spider on GitHub or tag @TheoA so he will be aware of them and help you to fix it.

Here is what I see for 111.xml Spider gbXML Viewer R12

What is missing for you or what are the issues?

In any viewer everything is OK, except Honeybee. image

Can i send u a ArchiCad file de try ?
Cause it’s doen’t work fine…

@TheoA I have the same problem. I can see the windows in the viewer, but not in Honeybee

The problem is only when using ArchiCad file, but if using REVIT to Gbxml, the translation is well…

Hello, I have exactly the same error with OpenStudio.OpenStudioGBXMLPINVOKE
I just updated Openstudio to recent version…

Solved by downgrading Openstudio from 3.0 to 2.5

Hi, and thanks for the good advice. Everything worked fine with the import of the gbxml, but unfortunately I do not get the Viualize Results in the plan view. Any tips? Or can you share a file? Everything seems to be fine, without any errors.

Maybe that is a silly answer, but have you tried to “show” the last component? In screenshot it is dark grey which suggests it being “hidden”