Import gbXML file generated from ARCHICAD

I have another problem. All gsXMLs exported from ARCHICAD Ecodesigner cause this error

"0. Runtime error (ApplicationException): C:\Git\OS\openstudiocore\src\utilities\time\Date.cpp@448 : Bad Date: year = 0, month = Jan(1), day = 1.

  1. Traceback:
    line 183, in script"

Could you help with this, please?

From the error message it seems there is a date in your XML file with the year 0 which is an invalid input. You can open the XML file and change the field manually or fixed it from the source in ARCHICAD.

Self editind useful thing, thank you.

Next problem with windows

online viewer shows windows and ladybug importer reports: "A very tiny glazing is removed from SW_-_002… but they are not so small… at the same time there is no problem with the door.

There used to be an issue in Rhino 6 that it was returning negative areas but I can see that you are using Rhino 5. Can you upload the xml file?

111.xml (173.5 KB)

I can import the file with no issues. I’m using a newer version of the component. Update Honeybee and use one of the recent versions of OpenStudio and it should work fine.

1 Like

Sorry. I couldnt understand how to update honeybee. your node is SEP_26_2018, my is JAN_20_2018 - the last downloaded from food4rhino. Update node tell that everything is up to date. on github i only find branch for honeybee plus. After updating openstudio to 2.7.0 the file doesn’t open at all. Help, please(

Did you try to insert a new component from Honeybee tab after update and restarting Rhino and Grasshopper?

You can also use update_file component to update the components in your file after updating the installation using Update_Ladybug and Update_Honeybee components.

Dear Blondahouse,

I have to try your file, 111.xml, which export from Archicad to import in ladybug-honeybee, of course it’s really work, but I try to set a model in Archicad before export a file, unfortunately every time it doesn’t work. So would you please give me a guide to set a model before export it. Thanks you very much guy.

After updating Honeybee, uninstalling openstudio 2.5.0 and installing openstudio 2.7.0
in rhino 6

in rhino 5 (64) after setting boolean toggle “true” rhino crashes with this report
in rhino 5 (32) importgbxml node gives report
“1. Solution exception: An initializer of the type “OpenStudio.OpenStudioGBXMLPINVOKE” threw an exception.”

What do you think?

in my case Archicad gbxml in Honeybee gives some errors about dates, I don’t know how to fix it in ARCHICAD
It creates some schedules and don’t mentioned years
So I delete this schedules and file is open

Don’t start energy simulation in archicad, and honeybee will working without editing xml.
Just set thermal zones, constructions, openings and save gbxml at once.

1 Like

Thanks for contributing!, but I don’t understand how to set that as in a picture.

open xml file in any text editor (sublime text in my case), start the search “schedule” and remove all lines between and including brackets e.g. “<Schedule ***> *** </ Schedule>”

1 Like

Hi, Mostapha
Sorry for the intrusiveness, but I really ask for help. I need windows in the grasshopper. I tried everything I could think of to fix it. I have reinstalled all components in different sequences many times. I installed the latest components from the installation instructions. You wrote to use one of the latest versions of openstudio. I tried to install the last 3 (2.5 2.6 2.7). But unsuccessfully. Windows do not appear.

After updating the honeybee, it issues a report that does not look like on your screenshot. In my report 13 lines while in your 4. Maybe this will help to understand the problem.

Please help.

Not sure what is the issue here. You are successfully updating the installation. Close Rhino and Grasshopper and re-open them. Then bring the updated components from Grasshopper tab which should be the new version.

Your OS is MAC or WINDOWS?

If this is a question for me it is Windows.

There is another solution to this problem; the idea it’s that u don’t need to define any scenario, it’s mean that u don’t affect ur building zones and export ur file before runing the simulation on Archicad. .

I’m having the same probelm, but I can’t find that field in xml file to fix it. Can you please explain what needs to be changed in xml file? Thank you.