Importing geometries into Rhinoceros 5.0 for daylight analysis in Grasshopper


I am trying to import 3D geometries into Rhinoceros in .dwg format. They appear in the canvas as Block instances. I have tried several things:
- Explode the block instance into mesh -> mesh to nurb --> and then i get polysurfaces
- Explode the block instance into mesh -> mesh to nurb --> and then i get polysurfaces -> explode to surfaces
- Exploed the block instance into mesh
- Explode the block instance into mesh -> mesh to nurb -> mergeAllfaces.

My problem is always the same. When i open GH and i use, for instance, Geometry pipeline sometimes is ok. Mostly working with polysurfaces. But when i try to create HBSurfaces it just crashes.

My question is, what would be the best way to import geometries in Rhino so it is easy to handle the surface in GH (probably dwg is not the best) how/what could i export from revit?. Could it be also a problem of memory? If i explode the blocks into surfaces can be up to 100k surfaces in total (if i merge them it reduces the number drastically).

Is there a way or format to make this simpler?
What is your experience in importing to Rhino for using into GH?

Thanks a lot!

Hi,@R_Bergel If you have revit model, you can export the room as gbXML file. Then , you can import gbXML to Grasshopper using Honeybee.
You can refer to this website.

Thanks @minggangyin !!!

Unfortunately, i dont have the subscription in revit for Energy optimization so i cannot saved any file as gbXML. Ive there is any other way i would apreciate tips.

I was trying anyways with a -xml file i got as an example from internet and i tried the component Honeybee_gbXML to Honeybee but it does not work. got an error:

"Runtime error (TypeInitializationException): Typinitieraren för OpenStudio.OpenStudioGBXMLPINVOKE utlöste ett undantag.
line 182, in script
It is swedish but means 1. Solution exception: The OpenStudio.OpenStudioGBXMLPINVOKE type initializer triggered an exception

or something like that

I was googling a bit and it may be because of my OpenStudio version, which is 2.9.1… Is the component compatible with this version ??

Thanks a lot in advance!