Indoor airflow simulation result

Hello I am new to the butterfly simulation and I was trying the simulation for indoor airflow.
I successfully tested the example file so I modify the file to my case, but the result comes out strange though.
Any suggestions? (432.8 KB)

By the way, the mesh that created is really strange but I think the boundary setting is ok though…?

The rhino geometry is missed in your grasshooper definition . Please upload it for further discussion.

Hi, sorry for the late reply, here is the file:

There are serval bug for your grasshooper definition.

  1. refine will should be more higher to retain the shape of geomertry.
  2. The X/Y/Z mesh count should be more.

    3.the surface level should equal to max refine level.

    Here is the screenshot of velocity in Rhino.

    And I suggest you to use paraview for visualization.

Thank you so much for the reply, sorry but I have a few questions though…

  1. may I ask what does the refine level mean? Why should I set to (4,4) instead of the example file (2,2)?
  2. Number 3: the surface level should equal to max refine level. I’m not sure which of the screen shot setting made the surface level equal to the max refine level?


The value of refine level depends on the details of the geometry.East and west windows are thin and long. You should set a grid for east and west windows,so you should set high level for them.

The refine levle I set is (4,6).So the surface level is 6.

Hi @minggangyin
How did you determine the cell count? I’ve tried to input 3 numbers like you did but it produced very large numbers for velocity with the majority of the cells stayed at blue (lowest number)

After I disconnected the cell_count the result seems to be correct, however I want to get finer result than that

hello, could anyone help me? I tried to run the simulation but the result is not what I needed to be.

I can’t find the error on the model.

20032021 Scripted Pasar Rumput Lantai Hunian (634.2 KB)

thank you in advance.

@minggangyin could you please help me with this? Thank you.

@tsuwys You model is complex. So the meshing maybe failed. Please check the mesh and make sure all the meshing is inside of room.

@minggangyin ah I see, let me check. May I ask about something else? when we’re define the refine levels, is there any provision before changing the numbers?

@tsuwys You should study the blockMesh and snappyHexMesh setting in OpenFOAM.
Here is a nice tutorial for this.

@minggangyin thank you so much for your help.

are this simulation with buttrfly