Ironbug Beta Release (outdated)

Hi Mingbo, I downloaded your latest Ironbug release just this past week and followed the installation instructions exactly on two different machines (to rule out firewall as a problem), and I do not see any of the HVAC components in Grasshopper. Please see the attached screenshot. All I see is the Mingbo_Dev tab and the Honeybee Export to Openstudio component. Please advise, I’m happy to provide further info as needed.

Hi @Jabboud,

I am not sure where you downloaded the “lastest” version. Did you check this Ironbug Preview Release

Hi @MingboPeng,
I have a wish regarding the PlantBranches component. It would be nice if this component keeps up the data tree structure of the input data tree. The AirLoopBranches component does this already and sends the information correctly to Openstudio. (see image below) The PlantBranches component somehow simplifies/flattens the data tree structure.

Hi @Erikbeeren

AirLoopBranches component is different than the plantBranches component, which is because in the airloop, each airloop branch can only have one thermalzone, whereas in plant loops, you can add more than one objects in one branch.

Meanwhile, when creating the air loops, it is likely to model multiple loops based on the zoning/floor, etc, so in AirloopBranches component, it automatically puts each thermal zone in one single airloop branch, and creates multiple loops if the input data structure is branched.

This is an example of plantBranches that some branches have more than one item.
3 branches:

In your case:
the result will be 6 branches:

  • -branch#1: 6 items
  • -branch#2: 6 items
  • -branch#3: 8 items
  • -branch#4: 6 items
  • -branch#5: 6 items
  • -branch#6: 8 items

if you want to put each item into each branch individually, you could use “Graft” to make each branch has only one item.

ps: instead of replying to this topic (Ironbug Beta Release), please post a new post if you have any other questions. It’d be easier for others to search the similar question later:>


Hi @MingboPeng,
Thanks for your reply. With grafting I already tried, but I didn’t succeed to generate different loops with different branches (in my case 6 apartments on 1 floor and each apartment with its own plant loops). Finally I succeeded by exploding the tree and model each branch separately, but this gave a huge amount of spaghetti. (see image below)

This generated all desired plant loops in openstudio. (see image below)

And this one.

The reason I like the way the AirLoopBranches component is structured is that it reduces the amount of spaghetti and is more easy to put into a automated workflow without having to explode tree structures.

Just one node…

But 6 Loops generated!

Hi @Erikbeeren,

That makes totally sense in your case.
In the most projects I have worked on, typically it only need one or two or three plant loops, and each plant loop is totally different than others.

Let me add a switch in PlantloopBranches component for you to automatically put each item per branch, and make a loop per gh_branch, just like AirloopBranch.


Super! @MingBoPeng,

That would be great!

Hi @Erikbeeren,

Please download the update zip file, and unzip (unblock zipfile first) to C:\Ironbug, replace the old files.
I attached my test gh file as well.
I only tested a couple simple files, haven’t really tested in complex loops. Please test carefully, and double check if it generates the correct loops.

Please let me know if you find any bugs,

Map branch to (22.7 KB)
Ironbugv0.0.12(20190624update).zip (264.1 KB)

Object: Ironbug_AirTerminalSingleDuctUncontrolled (level 1)

Object: Ironbug_AirTerminalSingleDuctUncontrolled (level 2)
未能从程序集“OpenStudio, Version=, Culture=neutral, PublicKeyToken=e86b6217592bda30”中加载类型“OpenStudio.AirTerminalSingleDuctUncontrolled”。

hey Mingbo, thx for your work but I found a problem after install the ironbug into my gh. And the error is post as you can see. Is there any solution that I could fix it and run the function normally. Now all the component of loop components, air terminals, zone equipments and sizing&control cant work. Thanks again.

Hi,@hqiuad It is a simple question. I remember that Ironbug only support openstudio Version 2.5.0.You should use this version.

@hqiuad please download the newest version, OpenStudio 2.8 has been supported after Ironbug v0.0.13.

1 Like

Hi @MingboPeng, There’s no honeybee_export to open studio_1.ghuser in the latest zip files.

@XavierZhouLadybug Please update your Honeybee.

I’m sticking with the legacy version of ladybug and honeybee now because I’m afraid the new versions will create problems. Am I worrying for nothing? Which version do you recommend? Thanks.

@XavierZhouLadybug I meant update the newer version of legacy honeybee, not [+] version.

@MingboPeng, I’d like to update to the latest Ladybug/Honeybee release. Is Ironbug compatible?

Hi @LelandCurtis, yes, Ironbug works with the latest legacy plugin and OpenStudio 3.0+.

Note, you will need to check this if you are using OpenStudio3.0+ How to get Honeybee Legacy working with OpenStudio 3.0


Hello, I have a problem istalling the ironbug.
I have open studio 2.5.0 and I tried downloading the Ironbug for doing HVAC simulations, but unfortunately, I cannot install it successfully.
I have the same problem as other users described in the past, not all components installed properly. I downloaded it and I followed various steps and instructions you gave to various users but still, I have very few components from ironbug. I have also the following messages as errors when I open the grasshopper now. I guess this happened because I tried multiple times installing the ironbug and delete it and install it again, but then this error continues to exist.

Moreover, i have seen that i have in my drive ©: 3 folders with the open studio 2.5.0 , does this play a role, do they overlap? Or are those just updated versions?
Can you help me with this problem? Thank you! Gina B.

Hi @Gina96, which version of Ironbug have you installed? Have you check the newer version: Ironbug Preview Release ?

thank you for the reply. I just followed this link, I do not know what I did differently this time but it helped me. Thanks! Now I have all the components and it seems it is working.