Ironbug Radiant Ceiling/floor error

Hi @MingboPeng,

We are a group of students investigating the impact of different construction types in combination with radiant systems. However, we are unable to get the radiant floor/ceiling system (template: System13_RadaintPanel + DOAS) to work, even when using the “INTERNAL SOURCE”-construction ‘hack’. Preferably our e.g. radiant floor would lay somewhat on top of the initial floor construction.

We get these errors when running the simulation:

  1. ** Severe ** [Branch][Chilled Water Loop Demand Branch 1][components][0] - Missing required property ‘component_name’.
  2. ** Severe ** [Branch][Chilled Water Loop Demand Branch 1][components][0] - Missing required property ‘component_object_type’.
  3. Solution exception: ** Fatal ** Errors occurred on processing input file. Preceding condition(s) cause termination.

We all have Ladybug Tools version 1.7.30, OpenStudio version 3.6.1 and EnergyPlus version 23.1.0.

I am not allowed to attach the GH file in this post, since i am a new user. Please let me know how I can send it to you if needed.

Best Regards
Trine and co.


Hi @TrineSM could take a screenshot about how you set up the system with your rooms?

Hi @MingoPeng,

Our original model contains HB materials added to the different constructions. But for simplicity we have tried to simplify our geometry so it only consists of a walled box with floor, ceiling and no windows (as you see in screenshot 2.) . (i am only allowed to add one screenshot at a time, so I will reply several times with a screenshot in each)

  1. Overview of script:
  1. Building geometry:
  1. Building geometry:
  1. Connection of template “System13_RadaintPanel + DOAS” to “HB Model to OSM”:
  1. The Error message:
  1. We have also tried to add the internal source construction to the room and that does not work either:

We hope you can help us. Thank you in advance.

Best regards
Trine and co.

It is not clear to see all details of your screenshot.
But it seems that you didn’t use the rooms with internal source construction for the simulation, you connected the rooms before assigning radiant construction.

Hi @MingboPeng,

We have tried that as well, ad we get the same errors.

We have tested out the template with a radiant ceiling on a new random box with no materials, constructions etc. (see screenshot). The template works fine (of course we get smaller errors on highly conductive construction due to no materials). We suspect that our issue is the our constructions with assigned materials (see screenshot on how we set up this in our original model in the next reply).

Can you spot the error in the construction setup, and/or do you have a solution to how you assign a radaint ceiling, when you have a ceiling construction?

The build up of the room, with windows has properties assigned to them. Each surface (Floors, ceilings etc.) goes into an HB face, where we assign a construction (see next reply).

We are finally able to upload a file. Here is the file we have trouble with.

Hope it makes our issue more clear. (256.5 KB)

1 Like

The way we assign materials to surfaces (this is done for the facade and internal walls) :

Next reply is what happens to the right of the picture (the final room with materials assigned)

The last screenshot showing the final model with materials:

As you can see, one of the members in my group (Freja) uploaded our GH script, where you can see everything, if needed.

Hi @TrineSM and @frejaejdrup,

I just checked your file, and this is the first issue that I mentioned before. You need to use the room with correct radiant construction for simulation, instead of the room from the step before setting up the radiant construction.

After you fix the above issue, the next good practice is: Always check your model after any changes.

Here in your model, when you set up the construction for radiant panel, you will need to verify if all room faces are set correctly.

Use “HB Color Face Attributes” to check your room face’s construction. You can see here the two screenshots show the roof construction before and after the radiant construction setup.

Nothing has been changed, and this is the reason. The radiant roof construction was only available for the exterior roof (outdoor) and your roof was set to adiabatic. Does it make sense now?

Now how to fix it:

  1. You can add the “Internal Source” layer in your “LightRoof” construction.
  1. Or, add another room above your test room and solve adjacency so that your test room’s roof/ceiling become a surface boundary condition (meaning indoor type), and the interior construction set could update the ceiling construction correctly.

Hope this helps.

1 Like