Ironbug_schedule(only specific time) is not working

Hi @MingboPeng
I use Ironbug to build PackagedVAV_Reheat (Ironbug is quite useful tool!),
and would like to control Fan ON/OFF based on the custom schedule.
However, EnergyPlus simulation not working well.
I tried the several times, but I cannot find the reason. Thank you in advance!

OpenStudioVersion: 3.5.1
EnergyPlusVersion: 22.2
Honeybee/Ironbug: I installed last week by using pollination installar. Maybe latest version. (197.7 KB)

Hi @Khan,

Are you trying to turn off the entire system based on your schedule? If yes, try to assign the same schedule to AvailabilitySchedule for the Airloop as well.

Hi @MingboPeng
Thank you for quick reply!
I also tried to assign the same schedule(turn off air system specific time) to AvailabilitySchedule for the Airloop.
But, EnergyPlus simulation was not working well (There is no results of Fan energy use and Fan air mass flow rates)
2~3 years ago, when I was using Ironbug with the Honeybee legacy version, I was able to apply the custom schedule successfully…
Looking forward to your reply!

Kind regards
Kan (210.4 KB)

Hi @Khan

Thanks, I think you found a bug here in the new workflow. I am checking it now.

Thank you! I appreciate your support.

Hi @Khan,

I have fixed the issue with assigning schedules. Please download the latest version of Ironbug.

1 Like

Hi @MingboPeng
I just installed the latest version of Ironbug and it works perfectly!
Thank you so much!!!

Hi @MingboPeng
Sorry to keep asking this question.
I need help with the schedule regarding the following items.
(1) I got an error message when I put in multiple schedules, such as weekday: ON/OFF and weekend: OFF.
(2)When I ran Energyplus with one schedule input (ON/OFF, weekday only), it was applied to all seven days as far as I checked the analysis results.
Looking forward to your reply!

Kind regards
Kan (205.5 KB)

Hi @Khan

Thanks for reporting the issue.

I spent some time and finally was able to trace down this bug. It should be caught by unit tests, but it wasn’t. It was because the deserializer failed to convert certain numbers to correct types.

I have just pushed a fix and you should be able to download a new version in an hour.
Dev by MingboPeng · Pull Request #78 · MingboPeng/Ironbug (

If you only have one ScheduleRule in the ScheduleRuleset, it is considered as a base schedule and is expected to apply for seven days. Even if you set Sunday and Saturday OFF, but EnergyPlus doesn’t know what to do with these two days.
When you are creating custom schedules for each weekday and weekend, make sure every day has a schedule value assigned.

1 Like

Hi @MingboPeng

Thank you so much!!
I’m now installing the newer version of ironbug and make sure everyday has a scheduled value assigned.
Everything works perfectly! I’m grateful to you.
Best regards

Hi @MingboPeng ,
I put my question here as it refers to the Ironbug Schedule component.

What is the correct way to inform the dateR_ input ?
When I connect LB_Analysis Period output it doesn’t work as I get “Date Range is not valid” error.
I get this message and the ScheduleRule component becoming red for any of the possible outputs : period, hoys or dates.

Any help would be very appreciated


Hi @Aymeric thanks for posting the issue here. It was a bug that the ScheduleRule only supports the AnalysisPeriod from the legacy version of Ladybug.

I have just pushed a fix and you should be able to download a new version in an hour.
fix(ScheduleRule): support LB Analysis Period of LBT by MingboPeng · Pull Request #80 · MingboPeng/Ironbug (

Thanks again.


Hi @MingboPeng

It seems it doesn’t work for me…
I don’t get the error anymore but the settings are not taken into account in the .IDF
See images attached