Ladybug cannot do the right analysis on rotated geometries

Hello all,

I tried to analysis sunlight on building massing. However I find it does not get the right result on some rotated geometries. (some have the blue strips but it should not appear). I also tried on single geometry. I find the blue strips appear after I rotate the geometry. Anyone knows why this happen?

Thank you

Hard to say without the file, but i would check the normal direction of the surfaces.

I am sorry I am a new user so I cannot upload the attachment file. But I can show you some screenshot. Thank you very much.

Left side is the geometry which is facing north. Right side is the Geometry I rotated. You can find that the right one has some strange blue strips.

And this is the screenshot for GH

Hallo liumo,
I think that building (with the blue string) has a duplicate geometries in the same position and maybe the duplicate geometries has the surfaces in the wrong direction:

You can check with the _seldup Option

Hello gaetano.christian.ruvio,

Thank you for your reply.

But I have tried to remove the duplicate surface, it still has the some problem. And those are all solid so it cannot flip surface

Send a link for the file, until you can upload here.
Also you don’t need to connect the geometry to the context. Unplug it from there.

Hello Abraham,

This is the definition for GH.

Thank you very (404.9 KB)

Residential_test.3dm (1.4 MB)

and this is the rhino file for test

Did it work once you removed the geometry from the context_? From my understanding context_ should be used for surfaces you want in your raytracing but don’t want analysed. Surfaces plugged into _geometry will by default also act as context (otherwise everything would be 100% radiated right?).

Also, have you considered rotating the North position rather than the geometry? This will be less heavy in terms of compute for grasshopper (less error prone).


Your geometry is too far away from the origin (0,0,0). Theoretically it is not supposed to affect … but it does.
Move it close to origin and you’ll be just fine.

OK. I got the right result!

Thank you very much!