Ladybug capture view component Problem

Hey guys,

I have a problem with ladybug capture view component. I cannot figure out the problem. I am trying to get a point in time daylight simulation for 9 different times of the year and I have set it to automatically capture view in my drive C after each simulation, but I am not getting any result. The captured views in my file does not show recolormesh visualization. It is just the plan. I don’t know what it is that I am doing wrong. I have checked many times and nothing seems wrong.

When I do this simulation one by one I get the result on my rhino interface and I can capture and print that myself. But the capture view component does not work for me. And the problem is I am not getting any error so I can realize my problem. It is just not captured properly with recolormesh component. I have attached related images so you can better understand my problem. I will appreciate your help if you can tell what might be the problem. Looking forward for your response.

Try ‘Top’ instead of ‘top’. View names are case sensitive. Right now it’s capturing the Perspective view.

Another solution is to change your active view to the top view.


Dear Mostapha,

Thank you for your response. I have tried both of them. The problem is that this component does not capture the recolormesh result. It just captures the plan without any simulation results when I set it to automatically save 9 images. So I have to do it one by one and it will be so time consuming. If you can help me find the problem with my file it will be awesome and I will really appreciate that. Thank you so much.

Looking forward for your response.

It happens because of the order of the execution in Grasshopper. You have inserted recolorMesh after capture view so it captures the view first and then recolors the mesh. Select capture view component and press Ctrl+F. This will bring the component forward so it will execute last.

Great yes that was the problem. It solved. Thank you so much for your help.