Ladybug Colors not showing in Rendered mode, Rhino 7 WIP

Hi everyone,

I’ve been running some tests using Rhino Inside Revit with the Rhino WIP. I just started seeing a problem where the ladybug results meshes, don’t render correctly when in the “Rendered” display mode. Here it is in shaded:

and here it is in rendered:

In rendered mode everything renders as gray. I checked that there weren’t any other custom display components floating around on the canvas that could be rendering on top of the ladybug mesh, and there’s nothing there. I’m wondering if this is some conflict between how ladybug assigns the materials to the mesh and how the Rhino 7 WIP is rendering things? Any help would be greatly appreciated

Thanks!

Hi @wim, any idea why this might be happening?

1 Like

Hi Dennis - could you upload a .gh file that I can try?
-wim

1 Like

Hi @wim and @mostapha,
So I was just digging deeper and somehow my rendered mode settings had been changed, so once I restored the defaults it worked! Thanks for your help!

1 Like

Hi @wim, I just wanted to follow up on this as I have run into issues again and have nailed down a little more when this problem pops up. It seems to only happen in rendered modes set to “Ambient Occlusion”. This is doesn’t happen in Rhino 6, so it seems to be isolated to the Rhino 7 WIP.

Hi Dennis - Is this a Grasshopper-only issue are is the display the same once the meshes are baked to the Rhino document? Can you provide a sample that I can check? Either a Ladybug result that you simply internalize in a mesh parameter or the baked Rhino file.
-wim