Ladybug dynamo nodes giving error on Revit 2020

Hi,

I tried using the ladybug package for the first time in revit 2020, and the two nodes that I tried (Calculate HOY, and Import Location) were giving me the same error:

ERROR:
	invalid literal for float(): DynamoForRevit

If you think this is a bug submit an issue on github.
https://github.com/ladybug-tools/ladybug-dynamo/issues
and include below error message:

Traceback (most recent call last):
  File "<string>", line 55, in <module>
  File "<string>", line 18, in tryGetPluginPath
ValueError: invalid literal for float(): DynamoForRevit

Is there anything I’m possibly doing wrong? How can I make it work?

Hi @sed07, I submitted a request today to get access to Revit so I can test it myself. Meanwhile this PR may address the issue:

Hi, I also get the identical error in Revit 2020 with the Import EPW node (tried with several different EPW files).

Dear Friends did you find a solution to this . I am currently struggling with the same issue

Hello Mostapha

I am having the same problem. I am using Revit 20, having 2.1.0 Dynamo and 0.1.7 Ladybug (I tried to install the latest 0.2.1 version of ladybug. However, environmental analysis folder is missing with this version)

Thanks.

Hello, I’m having the exact same issue. Are there any solutions yet?

Hi all,
I am getting the same issue.

Dynamo 2.2.1.5175
Revit 2020
Ladybug 0.2.1

Any updates?

Thanks in advance!