Ladybug_Envi-met building terrain problem



Hi everyone,

I am currently trying to use Gismo and Ladybug to generate terrain, and import the geometry into Envi-met for further simulation. However, when I connect terrain generated from Gismo to Ladybug_Envi-Met Building Terrain, warning will occur showing ‘’ Please move terrain’’. I tried to build terrain in a number of different ways, but couldn’t work it out. Does anyone know how to solve this issue?

Thanks a lot!



Hi @chfyhpyyy129,
Hard to say without looking at how your buildings sit on the terrain. Why don’t you try to move the terrain in the +z direction as the component warning says? Looks like the buildings and the terrain are not being intersected.


Hi @chfyhpyyy129,

the component which you use does not exist anymore, I have written several new components for ENVI_MET You can find the latest version of them on Github: lb_envimet
Here is a small workflow let you add a terrain in ENVI_MET.

the terrain you have is huge, you can control the portion of it to import using the basesurface input.

Here is the results in ENVI_MET.

The component that moves and cuts buildings is not perfect yet, I suggest you create closed breps with native grasshopper components.



Thank you Antonello!! It worked well.