Ladybug-epwWeatherFile address is not valid.epw file

Hi Guys

I have an issue I hope I can get assistance with. The weather file is not being picked up for a Radiation rose analysis. However I have used the same file for the Wind rose and visualization of climate data. When i swap the file out for the 30163_Pretoria_2007_csv__2001.epw the Radiation rose works. I’m not sure whats the cause of this.

I normally put the Path component after the weather file details and connect the path up to the epw file

Hi Shanice, I will try that out and see if it works. Thanks

Hi, Shanice
I have the same problem and I tried with path, but it doesn´t work. I would like to know if you (or anybody else) know how can I fix it.
Thank you

@Shanice, some of the links in epwmap are not working mainly because they refer to a wrong file name, wrong years, etc. But, till LBT developer find time to resolve the issue, if you go to onebuilidng site itself, you can find the link that works. For example, for Africa:


Since you are giving an explicit path for the EPW file, you need to connect the panel to the proper input (_epw_file) of the location component, or others, instead of the download_Weather.


Thank you so much @AbrahamYezioro I checked the input and you’re right, I changed the component and now it´s running without problems.

I’m struggling to open epw files in Ladybug 1.6. I tried to download from and also from
This fails both using url option and local file path option. I have tried all suggestions above.
I upgraded to LB 1.6 because the same issue was persistent in LB 1.5.
Thank you if you have same suggestions.

It seems to be working right. The panel is telling you that the DBT has 8760 values, so what is the problem, or what is it that you expect to receive here?
If you connect the output to a LB_HourlyPlot you’ll visulaize the data.

Thank you @AbrahamYezioro
My mistake. I’venow managed to use the weatherdata. I believe in the Legacy Version connecting output (e.g. dry-bulb temperature) to a panel would list all the 8760 values.
Thank you.

And now “deconstruct data” brings the data stream.